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Legal Information
The information provided in this document contains general descriptions, technical
characteristics and/or recommendations related to products/solutions.

This document is not intended as a substitute for a detailed study or operational and
site-specific development or schematic plan. It is not to be used for determining
suitability or reliability of the products/solutions for specific user applications. It is the
duty of any such user to perform or have any professional expert of its choice
(integrator, specifier or the like) perform the appropriate and comprehensive risk
analysis, evaluation and testing of the products/solutions with respect to the relevant
specific application or use thereof.

The Schneider Electric brand and any trademarks of Schneider Electric SE and its
subsidiaries referred to in this document are the property of Schneider Electric SE or
its subsidiaries. All other brands may be trademarks of their respective owner.

This document and its content are protected under applicable copyright laws and
provided for informative use only. No part of this document may be reproduced or
transmitted in any form or by any means (electronic, mechanical, photocopying,
recording, or otherwise), for any purpose, without the prior written permission of
Schneider Electric.

Schneider Electric does not grant any right or license for commercial use of the
document or its content, except for a non-exclusive and personal license to consult it
on an "as is" basis.

Schneider Electric reserves the right to make changes or updates with respect to or in
the content of this document or the format thereof, at any time without notice.

To the extent permitted by applicable law, no responsibility or liability is
assumed by Schneider Electric and its subsidiaries for any errors or omissions
in the informational content of this document, as well as any non-intended use
or misuse of the content thereof.



Table of Contents

Safety Information.......................................................................................5
Before You Begin........................................................................................5
Start-up and Test ........................................................................................6
Operation and Adjustments .........................................................................7

About the Book............................................................................................8

Introduction to EcoStruxure Control Engineering -
Verification .................................................................................................14

Registration, Login, Account Settings, Licenses and
Sessions.....................................................................................................15

Registration .............................................................................................15
Login .......................................................................................................17
Account Settings ......................................................................................18
Licenses ..................................................................................................20
Sessions..................................................................................................22

Creating Projects and Programs ............................................................23
Introduction to Projects and Programs........................................................23
Creating Projects and Programs ................................................................24
Program Creation Wizard..........................................................................26
Overview of the Program...........................................................................30
Accessing a Shared Program ....................................................................31
Sharing Programs with Other Users ...........................................................32
File Repository of Programs ......................................................................34

Verifying the Code of Controller Applications .......................................35
Running a Verification of a Controller Application ........................................35
Displaying Code Verification Results ..........................................................36
Market Trends ..........................................................................................39
Justifications for Exceptions ......................................................................41
Rules and Rules Files ...............................................................................42
Verification Settings ..................................................................................47
EcoStruxure Control Expert Plug-In for EcoStruxure Control Engineering
- Verification .............................................................................................48
Limitations of the Free Trial Version ...........................................................51

Manufacturer-Specific File Export Procedures.....................................53
EcoStruxure Control Expert (.XEF / .ZEF / .XVM File Export) .......................53
EcoStruxure Machine Expert (.EXPORT File Export)...................................54
EcoStruxure Machine Expert Basic (.SMBP File Export) ..............................56
PL7 Pro (.FEF File Export) ........................................................................57
3S CODESYS V3 (.EXPORT File Export) ...................................................58
3S CODESYS V2 (.EXP File Export) ..........................................................60
BECKHOFF TwinCAT V3 (.XML File Export)...............................................62
PHOENIX CONTACT Multiprog v5.5 (.XML File Export) ..............................63
Rockwell Automation® RSLogix 5000® or Studio 5000 (.L5K File
Export).....................................................................................................64
Siemens SIMATIC STEP 7 (.ASC, .AWL, .GR7 and .SCL File
Export).....................................................................................................65
Siemens TIA Portal SIMATIC STEP 7 (.ZIP File Export)...............................74

EIO0000004424.06 3





Safety Information

Important Information
Read these instructions carefully, and look at the equipment to become familiar
with the device before trying to install, operate, service, or maintain it. The
following special messages may appear throughout this documentation or on the
equipment to warn of potential hazards or to call attention to information that
clarifies or simplifies a procedure.

Please Note
Electrical equipment should be installed, operated, serviced, and maintained only
by qualified personnel. No responsibility is assumed by Schneider Electric for any
consequences arising out of the use of this material.

A qualified person is one who has skills and knowledge related to the construction
and operation of electrical equipment and its installation, and has received safety
training to recognize and avoid the hazards involved.

Before You Begin
Do not use this product on machinery lacking effective point-of-operation
guarding. Lack of effective point-of-operation guarding on a machine can result in
serious injury to the operator of that machine.

The addition of this symbol to a “Danger” or “Warning” safety label indicates that an 
electrical hazard exists which will result in personal injury if the instructions are not 
followed.

This is the safety alert symbol. It is used to alert you to potential personal injury 
hazards. Obey all safety messages that follow this symbol to avoid possible injury or 
death.

DANGER indicates a hazardous situation which, if not avoided, will result in death or serious 
injury.

! DANGER

WARNING indicates a hazardous situation which, if not avoided, could result in death or 
serious injury.

WARNING!

CAUTION indicates a hazardous situation which, if not avoided, could result in minor or 
moderate injury.

CAUTION!

NOTICE is used to address practices not related to physical injury.

NOTICE
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WARNING
UNGUARDED EQUIPMENT
• Do not use this software and related automation equipment on equipment

which does not have point-of-operation protection.
• Do not reach into machinery during operation.
Failure to follow these instructions can result in death, serious injury, or
equipment damage.

This automation equipment and related software is used to control a variety of
industrial processes. The type or model of automation equipment suitable for each
application will vary depending on factors such as the control function required,
degree of protection required, production methods, unusual conditions,
government regulations, etc. In some applications, more than one processor may
be required, as when backup redundancy is needed.

Only you, the user, machine builder or system integrator can be aware of all the
conditions and factors present during setup, operation, and maintenance of the
machine and, therefore, can determine the automation equipment and the related
safeties and interlocks which can be properly used. When selecting automation
and control equipment and related software for a particular application, you should
refer to the applicable local and national standards and regulations. The National
Safety Council's Accident Prevention Manual (nationally recognized in the United
States of America) also provides much useful information.

In some applications, such as packaging machinery, additional operator protection
such as point-of-operation guarding must be provided. This is necessary if the
operator's hands and other parts of the body are free to enter the pinch points or
other hazardous areas and serious injury can occur. Software products alone
cannot protect an operator from injury. For this reason the software cannot be
substituted for or take the place of point-of-operation protection.

Ensure that appropriate safeties and mechanical/electrical interlocks related to
point-of-operation protection have been installed and are operational before
placing the equipment into service. All interlocks and safeties related to point-of-
operation protection must be coordinated with the related automation equipment
and software programming.

NOTE: Coordination of safeties and mechanical/electrical interlocks for point-
of-operation protection is outside the scope of the Function Block Library,
System User Guide, or other implementation referenced in this
documentation.

Start-up and Test
Before using electrical control and automation equipment for regular operation
after installation, the system should be given a start-up test by qualified personnel
to verify correct operation of the equipment. It is important that arrangements for
such a check are made and that enough time is allowed to perform complete and
satisfactory testing.

WARNING
EQUIPMENT OPERATION HAZARD
• Verify that all installation and set up procedures have been completed.
• Before operational tests are performed, remove all blocks or other temporary

holding means used for shipment from all component devices.
• Remove tools, meters, and debris from equipment.
Failure to follow these instructions can result in death, serious injury, or
equipment damage.
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Follow all start-up tests recommended in the equipment documentation. Store all
equipment documentation for future references.

Software testing must be done in both simulated and real environments.

Verify that the completed system is free from all short circuits and temporary
grounds that are not installed according to local regulations (according to the
National Electrical Code in the U.S.A, for instance). If high-potential voltage
testing is necessary, follow recommendations in equipment documentation to
prevent accidental equipment damage.

Before energizing equipment:
• Remove tools, meters, and debris from equipment.
• Close the equipment enclosure door.
• Remove all temporary grounds from incoming power lines.
• Perform all start-up tests recommended by the manufacturer.

Operation and Adjustments
The following precautions are from the NEMA Standards Publication ICS 7.1-
1995:

(In case of divergence or contradiction between any translation and the English
original, the original text in the English language will prevail.)

• Regardless of the care exercised in the design and manufacture of equipment
or in the selection and ratings of components, there are hazards that can be
encountered if such equipment is improperly operated.

• It is sometimes possible to misadjust the equipment and thus produce
unsatisfactory or unsafe operation. Always use the manufacturer’s
instructions as a guide for functional adjustments. Personnel who have
access to these adjustments should be familiar with the equipment
manufacturer’s instructions and the machinery used with the electrical
equipment.

• Only those operational adjustments required by the operator should be
accessible to the operator. Access to other controls should be restricted to
prevent unauthorized changes in operating characteristics.
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About the Book

Document Scope
The present user guide describes the functionality provided by EcoStruxure
Control Engineering - Verification.

Validity Note
This document has been updated for the release of EcoStruxure Control
Engineering V24.2.

Available Languages of this Document
This document is available in these languages:

• English (EIO0000004424)
• French (EIO0000004772)

Related Documents
Title of documentation Reference number

EcoStruxure Control Engineering - Converter -
User Guide

EIO0000004425 (eng)

EIO0000004773 (fre)

EcoStruxure Control Engineering -
Documentation - User Guide

EIO0000004426 (eng)

EIO0000004774 (fre)

EcoStruxure Control Engineering - Monitoring -
User Guide

EIO0000004427 (eng)

EIO0000004775 (fre)

Cybersecurity Best Practices CS-Best-Practices-2019-340

EcoStruxure Control Engineering, Hardening
Guide

EIO0000004982 (eng)

To find documents online, visit the Schneider Electric download center
(www.se.com/ww/en/download/).
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Product Related Information

WARNING
LOSS OF CONTROL
• Perform a Failure Mode and Effects Analysis (FMEA), or equivalent risk

analysis, of your application, and apply preventive and detective controls
before implementation.

• Provide a fallback state for undesired control events or sequences.
• Provide separate or redundant control paths wherever required.
• Supply appropriate parameters, particularly for limits.
• Review the implications of transmission delays and take actions to mitigate

them.
• Review the implications of communication link interruptions and take actions

to mitigate them.
• Provide independent paths for control functions (for example, emergency

stop, over-limit conditions, and error conditions) according to your risk
assessment, and applicable codes and regulations.

• Apply local accident prevention and safety regulations and guidelines.1

• Test each implementation of a system for proper operation before placing it
into service.

Failure to follow these instructions can result in death, serious injury, or
equipment damage.

1 For additional information, refer to NEMA ICS 1.1 (latest edition), Safety
Guidelines for the Application, Installation, and Maintenance of Solid State Control
and to NEMA ICS 7.1 (latest edition), Safety Standards for Construction and
Guide for Selection, Installation and Operation of Adjustable-Speed Drive
Systems or their equivalent governing your particular location.

WARNING
UNINTENDED EQUIPMENT OPERATION
• Perform a risk assessment as per ISO 12100 and/or other equivalent

assessment in view of your use of EcoStruxure Control Engineering.
• In your risk assessment, consider all applicable regulations and standards

that apply to your development process and to your machine/process.
• Verify that your use of EcoStruxure Control Engineering is fully covered in

the definition of your software development process and that your software
development process meets all applicable regulations and standards.

• After modifications of any type whatsoever to the source code of your
application resulting from your use of EcoStruxure Control Engineering,
commission or recommission the machine/process in compliance with all
regulations, standards, and process definitions applicable to your machine/
process.

• During commissioning or recommissioning of the machine/process, verify
the correct operation and effectiveness of all safety-related functions and
non-safety-related functions by performing comprehensive tests for all
operating states, for the defined safe state of your machine/process, and for
all potential error situations.

Failure to follow these instructions can result in death, serious injury, or
equipment damage.
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No tool can provide analysis procedures for all potential types of code and
methods of creating code. For example, a code block in your source code may be
semantically invalid, but syntactically correct. The tool may not be able to detect
such a condition.

Software development environments may provide code protection features
intended to, for example, block access to intellectual property. Unlock such
protected code blocks in your software development environment before creating
export files to be used with EcoStruxure Control Engineering.

WARNING
INCORRECT OR INCOMPLETE SOURCE CODE ANALYSIS
• In your risk assessment, consider all potential effects of inappropriate,

incorrect, or incomplete input files used with EcoStruxure Control
Engineering.

• Verify that the source code exported from your software development
environment and to be used by EcoStruxure Control Engineering is complete
and up to date.

• After modifications of any type whatsoever to the source code of your
application resulting from your use of EcoStruxure Control Engineering,
verify the correctness of the modified source code.

Failure to follow these instructions can result in death, serious injury, or
equipment damage.

EcoStruxure Control Engineering - Verification may not be able to detect incorrect
or incomplete source code, depending on, for example, the analysis rules used.
The Schneider Electric default rules files are provided as are.

WARNING
INCORRECT OR INCOMPLETE SOURCE CODE ANALYSIS

Do not use the Schneider Electric default rules files, or rules files created or
modified by you in EcoStruxure Control Engineering without verifying their
appropriateness and completeness for the task at hand by appropriate
measures such as test cases.

Failure to follow these instructions can result in death, serious injury, or
equipment damage.

Machines, controllers, and related equipment are usually integrated into networks.
Unauthorized persons and malware may gain access to the machine as well as to
other devices on the network/fieldbus of the machine and connected networks
because of insufficiently secure access to software and networks.
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Schneider Electric adheres to industry best practices in the development and
implementation of control systems. This includes a "Defense-in-Depth" approach
to secure an Industrial Control System. This approach places the controllers
behind one or more firewalls to restrict access to authorized personnel and
protocols only.

WARNING
UNAUTHENTICATED ACCESS AND SUBSEQUENT UNAUTHORIZED
MACHINE OPERATION
• Evaluate whether your application environments are connected to your

critical infrastructure and, if so, take appropriate steps in terms of prevention,
based on Defense-in-Depth, before connecting the automation system to
any network.

• Limit the number of devices connected to a network to the minimum
necessary.

• Isolate your industrial network from other networks inside your company.
• Protect any network against unintended access by using firewalls, VPN, or

other, proven security measures, such as an Intrusion Prevention System or
Intrusion Detection System.

• Monitor activities within your systems.
• Prevent subject devices from direct access or direct link by unauthorized

parties or unauthenticated actions.
• Install certificates that are issued by publicly known Trusted Certificate

Authorities.
• Keep your systems up-to-date and rely only on legitimate sources.
• Prepare a recovery plan including backup of your system and process

information.
Failure to follow these instructions can result in death, serious injury, or
equipment damage.

For more information on organizational measures and rules covering access to
infrastructures, refer to ISO/IEC 27000 series, Common Criteria for Information
Technology Security Evaluation, ISO/IEC 15408, IEC 62351, ISA/IEC 62443,
NIST Cybersecurity Framework, Information Security Forum - Standard of Good
Practice for Information Security, and refer to Cybersecurity Guidelines for
EcoStruxure Machine Expert, Modicon and PacDrive Controllers and Associated
Equipment.

For reasons of Internet security, for those devices that have a native Ethernet
connection, TCP/IP forwarding is disabled by default. Therefore, you must
manually enable TCP/IP forwarding. However, doing so may expose your network
to possible cyberattacks if you do not take additional measures to protect your
enterprise. In addition, you may be subject to laws and regulations concerning
cybersecurity.

WARNING
UNAUTHENTICATED ACCESS AND SUBSEQUENT NETWORK INTRUSION
• Observe and respect any and all pertinent national, regional and local

cybersecurity and/or personal data laws and regulations when enabling
TCP/IP forwarding on an industrial network.

• Isolate your industrial network from other networks inside your company.
• Protect any network against unintended access by using firewalls, VPN, or

other, proven security measures.
Failure to follow these instructions can result in death, serious injury, or
equipment damage.

Consult the Schneider Electric Cybersecurity Best Practices for additional
information.
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Information on Non-Inclusive or Insensitive Terminology
As a responsible, inclusive company, Schneider Electric is constantly updating its
communications and products that contain non-inclusive or insensitive
terminology. However, despite these efforts, our content may still contain terms
that are deemed inappropriate by some customers.

Terminology Derived from Standards
The technical terms, terminology, symbols and the corresponding descriptions in
the information contained herein, or that appear in or on the products themselves,
are generally derived from the terms or definitions of international standards.

In the area of functional safety systems, drives and general automation, this may
include, but is not limited to, terms such as safety, safety function, safe state, fault,
fault reset, malfunction, failure, error, error message, dangerous, etc.

Among others, these standards include:

Standard Description

IEC 61131-2:2007 Programmable controllers, part 2: Equipment requirements and tests.

ISO 13849-1:2023 Safety of machinery: Safety related parts of control systems.

General principles for design.

EN 61496-1:2013 Safety of machinery: Electro-sensitive protective equipment.

Part 1: General requirements and tests.

ISO 12100:2010 Safety of machinery - General principles for design - Risk assessment
and risk reduction

EN 60204-1:2006 Safety of machinery - Electrical equipment of machines - Part 1: General
requirements

ISO 14119:2013 Safety of machinery - Interlocking devices associated with guards -
Principles for design and selection

ISO 13850:2015 Safety of machinery - Emergency stop - Principles for design

IEC 62061:2021 Safety of machinery - Functional safety of safety-related electrical,
electronic, and electronic programmable control systems

IEC 61508-1:2010 Functional safety of electrical/electronic/programmable electronic safety-
related systems: General requirements.

IEC 61508-2:2010 Functional safety of electrical/electronic/programmable electronic safety-
related systems: Requirements for electrical/electronic/programmable
electronic safety-related systems.

IEC 61508-3:2010 Functional safety of electrical/electronic/programmable electronic safety-
related systems: Software requirements.

IEC 61784-3:2021 Industrial communication networks - Profiles - Part 3: Functional safety
fieldbuses - General rules and profile definitions.

2006/42/EC Machinery Directive

2014/30/EU Electromagnetic Compatibility Directive

2014/35/EU Low Voltage Directive

In addition, terms used in the present document may tangentially be used as they
are derived from other standards such as:

Standard Description

IEC 60034 series Rotating electrical machines

IEC 61800 series Adjustable speed electrical power drive systems

IEC 61158 series Digital data communications for measurement and control – Fieldbus for
use in industrial control systems

12 EIO0000004424.06
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Finally, the term zone of operation may be used in conjunction with the description
of specific hazards, and is defined as it is for a hazard zone or danger zone in the
Machinery Directive (2006/42/EC) and ISO 12100:2010.

NOTE: The aforementioned standards may or may not apply to the specific
products cited in the present documentation. For more information concerning
the individual standards applicable to the products described herein, see the
characteristics tables for those product references.
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Introduction to EcoStruxure Control Engineering -
Verification

Overview
EcoStruxure Control Engineering - Verification (formerly known as PLC Checker)
is a static code analysis tool that evaluates the code for industrial controllers used
in automation. The tool helps to verify that the code respects the specified design
and programming rules. In addition, the tool provides information on key metrics.
You can use default rules or create your own rules for the verification.

EcoStruxure Control Engineering - Verification supports, for example, code
development or code migration processes by providing methods of determining
the quality of a controller application, as well as monitoring the development
progress and helping ensure process quality with consistent, automated code
reviews and code audits.

The code verification results are available in two views:
• Dashboard view: Graphical overview as a summary
• Result details view: List of messages indicating non-conformities

EcoStruxure Control Engineering - Verification is a Software as a Service (SaaS)
tool accessible using a web browser. It is an agnostic tool and supports controller
applications written for a variety of controller types and models such as
EcoStruxure™ Control Expert (formerly Unity Pro), EcoStruxure™ Machine Expert,
PL7-PRO, Siemens TIA Portal, Siemens Simatic Step 7, Rockwell Automation®

RSLogix 5000®.

Workflow
The typical workflow for EcoStruxure Control Engineering - Verification includes:

• Register for EcoStruxure Control Engineering - Verification, either with the
cloud version or with the dedicated server for your organization.

• Obtain licenses for working with EcoStruxure Control Engineering -
Verification. You can start with a free trial license to evaluate the functionality
and then upgrade to license plans adapted to the requirements of your
organization.

• Create the work structure by establishing one or multiple projects.
• Create one or more programs to use the code verification features of

EcoStruxure Control Engineering - Verification, including:
◦ Exporting the code of your controller application and uploading the code to

EcoStruxure Control Engineering - Verification.
◦ Preparing a rules file that defines the criteria for analyzing your controller

application. Default rules files are available for immediate use and can be
customized to meet your requirements.

• Review the results provided by EcoStruxure Control Engineering -
Verification.

14 EIO0000004424.06

Introduction to EcoStruxure Control Engineering - Verification



Registration, Login, Account Settings, Licenses and
Sessions

Registration

Overview
The EcoStruxure Control Engineering tools are accessible using the cloud version
or using a dedicated server for your organization.

The URL of the cloud version is https://ecostruxure-control-engineering.se.app/.

If a dedicated server has been set up for your organization, the URL is available
from your system administrator.

In both cases, you must create a user account to use the tools.

Browser Compatibility
The following web browsers are supported:

• Mozilla Firefox from version 102
• Google Chrome from version 127
• Microsoft Edge from version 127
• Apple Safari from version 17

Account Types
The following types of accounts are available:

• For the cloud version: Schneider Electric Account
• For the dedicated server version: EcoStruxure Control Engineering Account

Registration with the Cloud Version
Registration procedure:

Step Action

1 Go to https://ecostruxure-control-engineering.se.app/.

2 Click Use a Schneider Electric Account.

3 Click Register.

4 Enter your registration information and complete the registration by following the on-
screen instructions.

Registration with the Dedicated Server Version
Contact your system administrator to coordinate the registration before you begin
the registration procedure.

Registration procedure:

EIO0000004424.06 15
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Step Action

1 In your browser, go to the URL of the dedicated server.

2 Click Sign up.

3 Fill in the form with your first and last names, your phone number, your e-mail address
(which is used as your identifier) and select a password. Password requirements:

• At least one uppercase character
• At least one lowercase character
• At least one numerical character
• At least one special character (such as ”{”, ”/”, “$” )
• Password length at least 12 characters

4 Read the Terms and Conditions and, if you agree, select I agree to the Terms and
Conditions.

5 Click Sign Up.

Result: If the dedicated server version is configured to send emails, a verification e-
mail is sent to you. If the dedicated server version is not configured to send emails, your
account is activated immediately.

6 If the verification e-mail is sent to you: The email contains a link that you must follow.

Result: Your account is activated.

16 EIO0000004424.06
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Login

Logging into the Cloud Version Using a Schneider Electric
Account

Step Action

1 When your registration on the Schneider Electric account is completed and your
account is ready, go to https://ecostruxure-control-engineering.se.app/.

2 Click Use a Schneider Electric Account.

3 Enter your email address, click Next and then enter your password.

Result: After validation, you are redirected to your dashboard.

NOTE: If you use an EcoStruxure Control Engineering account but want to
migrate to a Schneider Electric account, create a Schneider Electric user
account that uses the same email address as your EcoStruxure Control
Engineering account. After the first login with a Schneider Electric account,
subsequent logins must be completed using your Schneider Electric account.
For more information on Schneider Electric accounts, contact your local
Schneider Electric service representative.

Logging into the Dedicated Server Version Using an EcoStruxure
Control Engineering Account

Step Action

1 In your browser, go to the URL of the dedicated server.

2 Enter your email address and password.

3 Click Login.

Result: After validation, you are redirected to your dashboard.

EIO0000004424.06 17
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Account Settings

Account Settings if a Schneider Electric Account is Used
The Settings page lets you access the personal information of the account and
the global EcoStruxure Control Engineering platform settings.

Step Action

1

In the Dashboard window, click .

Result: A menu is displayed.

2 Click Settings.

Result: The Settings page is displayed.

The Schneider Electric Profile tab displays your personal information such as
the identity, phone number and country. To update this information, you must edit
your Schneider Electric profile, which is accessible using the Schneider Electric
Account button.

The Third-Party Apps Settings tab allows you to generate a password to
connect your application to EcoStruxure Control Engineering if your application
does not support the Schneider Electric account authentication.

The Notifications tab allows you to configure the type of email notifications sent
to you by the web platform. For example, you can choose to receive a
confirmation email after a controller code analysis.

The View Settings tab allows you to select the default view for projects.

The Accessibility tab allows you to adapt the on-screen representation to your
personal needs, for example, high contrast colors.

The Privacy tab provides general information on privacy and on the cookies
policy. It describes how personal data is used and how you can exercise your
rights relating to personal data.

You can delete the personal information under the following conditions:
• If you are using the dedicated server version and if the server is configured to

send emails.
• If you are using the cloud version.

Account Settings if an EcoStruxure Control Engineering Account
is Used

The Settings page helps you to access the personal information of the account
and the global EcoStruxure Control Engineering platform settings.

Step Action

1

In the Dashboard window, click .

Result: A menu is displayed.

2 Click Settings.

Result: The Settings page is displayed.

The Profile tab displays your personal information such as the identity, phone
number and country. You can update this information at any time.

18 EIO0000004424.06
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The Password tab provides the password change form. You can change your
password at any time.

The Notifications tab allows you to configure the type of email notifications sent
to you by the web platform. For example, you can choose to receive a
confirmation email after a controller code analysis.

The View Settings tab allows you to select the default view for projects.

The Accessibility tab allows you to adapt the on-screen representation to your
personal needs, for example, high contrast colors.

The Privacy tab provides general information on privacy and on the cookies
policy. It describes how personal data is used and how you can exercise your
rights relating to personal data.

You can delete the personal information under the following conditions:
• If you are using the dedicated server version and if the server is configured to

send emails.
• If you are using the cloud version.
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Licenses

General
Schneider Electric offers various license plans for EcoStruxure Control
Engineering tools.

Paid License Plans
Contact your local Schneider Electric representative for details on the available
license plans for EcoStruxure Control Engineering tools. A selection of licenses is
also directly available from Schneider Electric Software Shop Catalog at https://
www.se.com/us/en/shop/software/?offerid=ECEE.

Free Trial Licenses
As of version 22.1 of EcoStruxure Control Engineering, free trial licenses are
available to help you evaluate the EcoStruxure Control Engineering tools after you
have created a user account. A trial license allows you to work with many of the
functions of the EcoStruxure Control Engineering tool. The number of results
provided by the tools and the available functions are limited if you use a trial
license. You can upgrade a trial license to a paid license.

Overview of Your Paid Licenses, Your Orders And Your Contract
In the main menu click LICENSES & ORDERS to get an overview of your paid
licenses, your orders and your contract.

The overview contains three tabs:
• The Licenses tab contains a list of your available licenses.
• The Orders tab contains a list of your orders.
• The Contract tab contains details of your contract.

Licenses Tab
The Licenses tab contains a list of licenses associated with your account. The list
contains information such as license ID, name and type.

The buttons Buy New Licenses On Schneider Electric Software Shop (cloud
version) and Order Licenses (dedicated server version) allows you to buy
additional licenses.

• If you use the cloud version, the Buy New Licenses On Schneider Electric
Software Shop button opens the Schneider Electric Software Shop Catalog
(https://www.se.com/us/en/shop/software/?offerid=ECEE). After the checkout
process, your licenses are automatically added to your account (within
approximately 30 minutes).

• If you use the dedicated server version, the Order Licenses button opens a
wizard. With the wizard you can add the licenses you want to buy. At the end
of the wizard you must download the license request file and send it to your
Schneider Electric service representative. The Schneider Electric service
representative sends you then a license file. You must install the license file
manually using the Install Licenses button.

The Quick Filters button allows you to filter your licenses. The licenses can be
filtered by logic controller brand or by expiration date (licenses that expire within
the next three weeks).
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The Transfer Licenses button allows you to transfer one or more licenses to a
different user. A license can only be transferred if the license has not yet been
used, has not expired and is not currently associated to a program.

Orders Tab
The Orders tab contains a list of orders associated with your account. The list
contains information such as name, status and description.

The details of an order can be displayed by clicking the name of an order.

Information for each order:
• The Overview tab shows details on the person who created the order and the

state of the order.
• The Order content tab shows details on the ordered products.
• The Licenses tab shows a list of the associated licenses.

If you use the dedicated server version, this tab allows you to download once
again the license request file for orders created via the wizard.

Contract Tab
The Contract tab contains details of your contract. A contract allows you to
provide seat licenses for a group of users and to set default Glips versions.

The Summary button provides a summary of your contract (contract name,
description, contract manager, company and subscribed products) and a list of the
members of the contract.

The Repository button shows a list of files that are shared between the contract
members, for example, the rules file.

As a contract manager, you can do the following:
• The buttons Reporting > Activity summary and Reporting > History show

usage statistics of the contract members.
• The Administrate > Contract members button allows you to add and

remove contract members.
• The Administrate > Default Glips versions button allows you to set the

default Glips version for each use case. Verify that the Glips version you
select meets your requirements and matches the specifics of the input code.
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Sessions

Automatic Log-Out (Session Time-Out)
After 11 minutes of inactivity in an EcoStruxure Control Engineering session, you
are automatically logged out. If you work with multiple browser tabs, the most
recent activity in any of the tabs applies. For example, if you work in tab 1, but not
in tab 2, tab 2 does not disconnect you because there is activity in tab 1.

Multiple Sessions
If your credentials are used in multiple sessions, you receive a notification. For
example, if you are logged in and another session is established with the same
credentials, you receive the following message:

The information on the connection date and time, the IP address, the operating
system and the browser help you to determine whether or not a session is
legitimate. You can select and close a session with Close Session(s).
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Creating Projects and Programs

Introduction to Projects and Programs

Overview
EcoStruxure Control Engineering provides projects and programs for you to
organize your work.

A project is a type of container that can hold programs. A project is not specific to
an EcoStruxure Control Engineering tool.

When you register with EcoStruxure Control Engineering, the platform provides
one default project for you.

A program is assigned to a project. A program is created in conjunction with one of
the tools provided by EcoStruxure Control Engineering. A program typically
comprises metadata you entered during its creation, the uploaded source code of
a controller application, and the results generated with the EcoStruxure Control
Engineering tools.

The EcoStruxure Control Engineering tools are launched from within a program.
Whether or not a specific EcoStruxure Control Engineering tool is available for a
program depends on the source controller/development environment you select
during the creation of the program (PLC Brand or PLC source brand).

Programs can be shared with other users.

Example
Assume you have been assigned the task of improving a machine ABC with two
controllers X and Y. In a first step, you want a deeper understanding of the code of
the two controller applications. You create a project “Machine ABC”. Then you add
two programs to this project: “Controller X” and “Controller Y”.

In both of these programs, you run EcoStruxure Control Engineering -
Documentation to visualize the data flow and the control flow.

In the next phase, you manage the creation of a new version of the controller
applications with improved quality. You start by running EcoStruxure Control
Engineering - Verification in your programs to verify the existing code. You share
the two programs with the developers so they can access the results of the code
verification for assistance in updating the code.

In subsequent phases, you can upload intermediate versions of the updated code
into your program and re-run EcoStruxure Control Engineering - Documentation
and EcoStruxure Control Engineering - Verification to document the progress and
verify that your coding rules have been properly implemented.
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Creating Projects and Programs

Creating Projects
Procedure for creating a project:

Step Action

1 Select PROJECTS in the top menu to display the Projects page.

2 Select Actions > New project.

3 Provide a unique name for your project. Lowercase and uppercase are ignored which
means that, for example, the name of a project to be created cannot be “Controller xyz”
if you already have a project with the name “Controller XYZ”.

4 Click Add to create the project.

Result: The project is added to your list of projects on the Open projects tab.

Clicking a project in the list displays three tabs. The Overview tab provides
general information on the project. The Programs tab contains the list of
programs assigned to this project. The Settings tab contains the project settings.

Creating Programs
There are three ways to start the creation of a program:

• From outside of a project select TOOLS on the main menu
• From the dashboard click New ...
• From inside a project on its Programs tab select Actions > New program
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Creating a program from outside of a project:

Step Action

1 From the main menu, select TOOLS to display a list of the available tools.

2 Select the tool you want to use for the program.

Result: EcoStruxure Control Engineering starts the program creation wizard.

Creating a program from the dashboard:

Step Action

1 From the main menu, select DASHBOARD.

2 Click the New ... button for the tool you want to use for the program.

Result: EcoStruxure Control Engineering starts the program creation wizard.

Creating a program from inside a project:

Step Action

1 From the main menu, select PROJECTS.

2 Select the required project from the list.

3 Display the Programs tab of the project.

4 Select Actions > New program.

Result: EcoStruxure Control Engineering prompts you for the tool to be used for the
program and starts the program creation wizard.
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Program Creation Wizard

Overview
A wizard guides you through the different steps required to create your program
and launch the selected EcoStruxure Control Engineering tool.

The project to which the new program is assigned depends on how the wizard is
started. If the wizard is started from outside of a project or from the dashboard, the
program is assigned to your default project. If the wizard is started from inside a
project, the program is assigned to this project. In both cases, the project
assignment can be adjusted in step 1 of the wizard.

Refer to Creating Programs, page 24 for details.

Step 1 - Start
The first step consists of providing setup information on the program.

Provide the following information:
• The fields Application name and Customer name are mandatory. The

defined Application name is used to identify the program in the different
views of EcoStruxure Control Engineering.

• Add additional information in the other fields so that you can identify this
program in your project.

Continue with the next step by clicking Validate And Next Step.

Step 2 - Parameters
The second step consists of selecting the development environment that was
used to develop the controller application.

In addition, you select the rules file to be used for the analysis of the source code.
You may use one of the default rules files, or upload your own rules file in step 4,
page 28.
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Select the PLC Brand and the Rules set.

If the source code is not a full controller application, but a library, select the
Library checkbox. You can also identify the source code as a library after the
wizard has been completed using the menu Admin > Settings of the
corresponding program.

Continue with the next step by clicking Validate And Next Step.

Step 3 - License
The third step consists of selecting the EcoStruxure Control Engineering license to
be used with your new program.

Choose one of the Licensing possibilities for this program:

Licensing possibilities Description

Do not assign a license now Select this option if you want to continue now and to assign a
license later on.

Use a license ID Select this option if you have a license code. If you have a
license, but the license has not yet been assigned to your
user account, you can still use it by entering its identifier in
the License #id field.

Use a free trial license Select this option to launch a trial version of the tool. This is
not possible if you have already used all trial licenses that
have been associated with your user account.

Use a contract license This option becomes available when you have a contract for
EcoStruxure Control Engineering. This allows you to
automatically generate a license, as part of your contract, to
run the analysis.

Use an account license This option becomes available when licenses are available
in your account. In this case, you can select the license from
a dropdown list.

Click Validate And Next Step to continue.

If no license is available, you can still continue creating the program by clicking
Validate And Next Step. In this case, a license can be added to the program after
you have created the program. Without a valid license, the EcoStruxure Control
Engineering tool selected for this program cannot be used.
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Step 4 - Source file
The fourth step consists of uploading the file with the source code of the controller
application that you have exported from the development environment (refer to
Manufacturer-Specific File Export Procedures, page 53 for details). This source
code is the input material for EcoStruxure Control Engineering. Depending on the
EcoStruxure Control Engineering tool used for the program, you may be prompted
to upload additional files.

Drag and drop the files to the location indicated or click Select Files… to import
the files. Also specify the rules file to be used if you have not selected a default file
in step 2, page 26.

Unwanted files can be removed with the garbage can symbol.

Then click Validate And Next Step to continue.

If the input files are not yet available when you create the program, you can skip
the upload with Validate And Next Step and provide the files at a later point in
time. Without the uploaded input files, the EcoStruxure Control Engineering tool
selected for this program cannot be used.

Step 5 - Summary
The fifth step displays a summary of the information you have provided in creating
your program.
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Review the information. If you want to make modifications, click Previous Step to
return to the step you want to modify.

If the information is correct, click Create Without Executing to create the
program or click Create And Execute to create the program and to start the
EcoStruxure Control Engineering tool selected for this program (this is possible if
you have selected a valid license and if you have uploaded the required files).
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Overview of the Program

General Information
After you have completed the wizard, the system displays an overview of the
program with the following tabs:

• Overview tab
• Tool-specific tab
• Admin tab

Overview Tab
The Overview tab displays program-specific information, such as creation date
and controller-related information.

The Glips version determines the way the code is interpreted.

The default Glips version for each program is either set by the system or, if you
are a Contract Member, by your Contract Manager.

You can modify the Glips version to be used for your program. This implies that
the results that you receive after a modification of the Glips version may be
different. Verify that the Glips version you select meets your requirements and
matches the specifics of the input code.

Tool-Specific Tab
The tool-specific tab allows you to access settings and results related to the tool
used for the program.

The menu <tool-specific> > User awareness > Execution messages allows
you to access the list of categorized messages regarding errors detected while
using the tool.

Admin Tab
The Admin tab allows you to access settings specific to the program.
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Accessing a Shared Program
If a program is shared with you, or if access to the program is not restricted (refer
to Sharing a Program, page 32), you can add it to your list of programs by
providing its unique program key. The unique program key can be found in the
program overview under Program key.

Procedure for adding a program to your list of programs:

Step Action

1 From the main menu, select PROJECTS to access the Projects page.

2 Click Shared programs to display the corresponding tab.

3 Enter the unique program key in the Add To My Programs field if you want to add this
program to your personal records for access at a later point in time.

If you only want to access it once without adding it to your list of programs, enter the
program key in the One Time Access field.

4 Click Add To My Programs or One Time Access, depending on the field in which you
entered the program key.
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Sharing Programs with Other Users

Overview
You can share your programs with other users so that a team can work on the
same project. As the owner, you can share your program. Selected users with
whom you share your program cannot delegate their access rights, that is, they
cannot share this shared program with further users.

In sharing programs, consider confidentiality rules that may apply.

There are two ways of sharing a program:
• Share with selected users: You choose who can access your program. By

default, other users cannot share this program because you are the owner.
• Share with everyone: Everyone can access your program.

Sharing with a Specific User
Procedure for sharing a program with selected users:

Step Action

1 Navigate to the Program page.

2 Select Admin > Collaboration > Users access rights to display the User
management.

3 Below Invited collaborators, select Actions > Add .

4 Enter the email address of the user to be invited. You can enter the email address the
user specified for registration with EcoStruxure Control Engineering, or you can use
any other email address. You can also send an invitation notification to the user. On a
dedicated server, the invitation notification function requires an email server.

Users added to the list of invited users can perform the same actions as you, except for
sharing the program and modifying its settings. If you do not want invited users to
perform any further actions, deactivate the program with the Active program checkbox
in Admin > Settings. This sets your program to read-only.

NOTE: If your program uses the EcoStruxure Control Engineering -
Verification tool, invited users may not be able to update the rules file and may
not be able to work with the Justifications function. Refer to the EcoStruxure
Control Engineering - Verification user guide for details.

You can revoke sharing by selecting the user account(s) you want to remove from
your program and selecting Actions > Remove access.

Sharing with Everyone
Procedure for sharing a program with everyone:
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Step Action

1 Navigate to the Program page.

2 Select Admin > Settings.

3 Deactivate the checkbox Private program.

Users accessing your program can perform the same actions as you, except for sharing
the program and modifying its settings. If you do not want invited users to perform any
further actions, deactivate the program with the Active program checkbox in Admin >
Settings. This sets your program to read-only.

NOTE: If your program uses the EcoStruxure Control Engineering -
Verification tool, invited users may not be able to update the rules file and may
not be able to work with the Justifications function. Refer to the EcoStruxure
Control Engineering - Verification user guide for details.

You can disable sharing with everybody by activating the checkbox Private
program. With this setting, only users explicitly invited can access your program.
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File Repository of Programs

General
Each program has a file repository. You can directly access the files belonging to a
program via the file repository.

File Operations
The Actions menu contains the following menu items:

Menu item Description

Add file You can add additional files to the repository.

Add file synchronized
with contract

You can add links to files contained in the contract repository which are
then available in your program repository. Any subsequent modifications
to such linked files in the contract repository are reflected in your
program repository.

Rename file You can rename a file in the repository.

Delete You can delete one or several files from the repository.

Get Checksum You can display the SHA256 checksum of one or several files in the
repository.

Use the following Windows PowerShell command to compute the
checksum of your local file:
Get-FileHash <Path to the file> -Algorithm SHA256 |
Format-List

The result is, for example:
Get-FileHash C:\Users\SE\Downloads\rulesset_
documentation.pdf -Algorithm SHA256 | Format-List

Algorithm : SHA256
Hash :
A5978FECDBE98C2C9C6479328AB2F717EBC239C9DA59-
D55015AD3D5D50C63750
Path : C:\Users\SE\Downloads\rulesset_
documentation.pdf

The Download Repository (ZIP) button lets you download the files contained in
the repository as a single zip file.
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Verifying the Code of Controller Applications

Running a Verification of a Controller Application

Procedure
No tool can provide analysis procedures for all potential types of code and
methods of creating code. For example, a code block in your source code may be
semantically invalid, but syntactically correct. The tool may not be able to detect
such a condition.

Software development environments may provide code protection features
intended to, for example, block access to intellectual property. Unlock such
protected code blocks in your software development environment before creating
export files to be used with EcoStruxure Control Engineering.

WARNING
INCORRECT OR INCOMPLETE SOURCE CODE ANALYSIS
• In your risk assessment, consider all potential effects of inappropriate,

incorrect, or incomplete input files used with EcoStruxure Control
Engineering.

• Verify that the source code exported from your software development
environment and to be used by EcoStruxure Control Engineering is complete
and up to date.

• After modifications of any type whatsoever to the source code of your
application resulting from your use of EcoStruxure Control Engineering,
verify the correctness of the modified source code.

Failure to follow these instructions can result in death, serious injury, or
equipment damage.

Step Action

1 Click Launch Verification on the Program page.

Result: EcoStruxure Control Engineering - Verification prompts you to upload new files
for the verification. If you do not have new files to upload, click Launch to run the
verification. If you have new files to upload, continue with step 2.

2 Upload the source files of the controller application exported from your software
development environment, as well as the rules file, if applicable, as described in
Program creation wizard, page 26.

3 Start the verification process by clicking Launch.
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Displaying Code Verification Results

Overview
After you run EcoStruxure Control Engineering - Verification for the first time, the
Verification tab provides access to the dashboard and to the verification details.

Dashboard
The dashboard provides a summary of the verification results. To display the
dashboard, click Verification > Dashboard.

The dashboard provides various metrics, for example, percentage values for non-
conformity to specific rules and an overall score of the verification result from A to
E. The scoring is based on the severity assigned to the five individual message
types.

Adapting Severities and Thresholds
In the project configuration, you can adapt the scoring by setting your own values
for the severities of the message types and for the thresholds for the individual
scores.

The severity and threshold values are set per project.
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To get a simulated result of your modified values click Simulate. On the next
screen enter the number of messages for the various severities and click
Simulate to visualize the result. Click Close to close the simulation screen.

Click Save Thresholds And Classes to save the modified severity and threshold
values.

Detailed Results
To display the details of the verification results, click Verification > Results >
Detailed results.

Selecting a rule to the left displays the corresponding messages to the right.

Search functions allow you to search for, for example, variables, locations in the
code or severity categories within messages generated by a selected rule.

The maximum number of messages per rule that can be displayed is 9999. If there
are more than 9999 messages per rule, they are contained in the PDF or CSV file
that you can download, page 38.

Market Insights Function
The Market Insights function compares the number of messages (per rule) of
your program to the number of messages of other code on the market.

Example:
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By default, the Market Insights function is disabled. For information on enabling
it, refer to Verification Settings, page 47.

NOTE: Use the standard rules files provided for the Market Insights function.
Modified rules files may lead to less accurate results.

Downloading the Detailed Results
The details of the verification results can be downloaded as a PDF file or a CSV
file.

To download the detailed results as a PDF file, click Verification > Results >
Download the detailed results PDF.

To download the detailed results as a CSV file, click Verification > Results >
Download the detailed results CSV.
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Market Trends

Overview
This function compares the results of the program analysis of your specific
program to other programs to the extent appropriate comparison data is available.

Select Verification > Results > Market Trends details to open the comparison
for the selected program.

The following sections are available:
• Your program metrics, which provides an overview of the metrics of your

program.
• Market metrics, which provides a comparison of the metrics of your program

to the metrics of other programs.

Section Your program metrics
The section Your program metrics provides an overview of the metrics of your
program.

The metrics of your program serve as a basis for the comparison to the metrics of
other programs.

Overview:

Halstead Metrics:
• Cyclomatic Complexity

Measures the difficulty a person may have to understand the code (for
instance, during code reviews)

• Essential Complexity
Complexity of the code unit for it to be able to do what it is designed to do

• Statistical number of bugs
Evaluation of the number of bugs expectable in the code unit (statistical
value, not a measured value)

Section Market metrics
The section Market metrics provides a comparison of the metrics of your program
to the metrics of other programs.

The following categories are compared:
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• Code density
Density of the number of instructions per code unit
An appropriate code density helps to reduce the code complexity, the number
of bugs and the maintenance costs, and increase the code readability,
memory footprint and portability.

• Theoretical number of bugs
Estimation of the number of bugs that can be found in the implementation
(appropriate testing strategy can help to mitigate)
Based on the content of the code units, it is possible to evaluate the probable
number of bugs this code unit contains. The more instructions, operators and
operands a code unit contains, the more it is prone to errors, resulting in bugs
in the implementation. The estimation provided here does no take in account
the programs test strategy.

• Cyclomatic Complexity
Measures the difficulty a person may have to understand the code (for
instance, during code reviews)
The Cyclomatic Complexity is the number of paths a code unit contains. For
instance, a code unit containing one IF/THEN/ELSE structure with one return
instruction in the THEN body and another one in the ELSE body has a
Cyclomatic Complexity of two. Lower Cyclomatic Complexity indicates
better readability and maintainability of code units.

Each category provides the following information (code density is used as an
example):

Item Description

1

Your program global
ranking

This section displays the ranking of your program.

Depending on the decile your program belongs to, two or three bars are
displayed.

If three bars are displayed, you see one bar each with the proportion of
programs with a lower score and a higher score than your program, and
a bar for your own program.

If your program is in the first or last decile, a bar for your program and a
bar for the neighboring decile are displayed.

2

How to improve

This section indicates the POU that may require the most improvements.

3

How to go further

This section provides information on best practices that may help
improving your code.
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Justifications for Exceptions
EcoStruxure Control Engineering - Verification generates a message for each
non-conformity with a rule it detects. However, there may be conditions in which
the choice of code was made for a valid reason and is not to be flagged for
improvement, for example, code on which the developer has no impact or code
relating to specific technology that cannot be implemented in a different way. In
such cases, you want to define a justified exception.

EcoStruxure Control Engineering - Verification provides a mechanism referred to
as Justification that allows you to ignore the corresponding message.

Procedure for removing a message from the list and entering a justification for the
exception:

Step Action

1 In your program, select Verification > Results details.

2 Select the checkbox of the message.

3 Select Actions > Justify.

4 Enter the reason for the justification.

5 Click Send to confirm the justification.

NOTE: To display a list of the justifications, their reasons and their authors,
select Verification > Justification in your program. You can remove an
exception and the justification by selecting Actions > Delete in this list view.
As a result, the corresponding message is generated again the next time you
run EcoStruxure Control Engineering - Verification.
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Rules and Rules Files

Introduction
The rules file is the file containing the rules used in the verification procedure. Only
the rules configured in the rules file specified for a given verification procedure are
applied.

A program can contain one or more rules files. However, only one of these rules
files is used in a given verification procedure.

A rule consists of two elements:
• A type which defines the verification operation of the rule. For example, the

rule can focus on comments, or on computing certain statistics.
• Configuration attributes that define how the rule operates. For example, the

attributes are used to select the elements to which the rule is applied, specify
the type of message to be displayed if a non-conformity is detected, or set the
number of messages to be generated.

The rules editor lets you customize attributes of rules.

Rules Editor
The rules in a rules file can be updated using the rules editor.

In your program, select Verification > Rules set > Rules editor to open the rules
editor.

Select the rules file you want to modify and click Edit in the Action column of the
corresponding row.

The rules editor provides the following buttons:

Buttons for the rules file:
• PROPERTIES: Allows you to display the properties of the rules file currently

being edited.
• SAVE PROJECT: Allows you to save the modifications to the rules file. Until

the modifications are saved, they are stored in a temporary location.
• SAVE AS: Saves the rules file under a different name.
• DROP UPDATES: Discards the modifications stored in the temporary

location.
Buttons for the rules of the rules file:

• ADD RULE: Adds a new rule from a list of pre-defined rules.
• DELETE RULE: Deletes a rule from the rules file.

The tree view to the left contains the rules hierarchy. You can expand the tree to
navigate in the hierarchy.
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Selecting a rule displays the configuration attributes that can be modified.
Additional information on the rule is available in the Help tab.

Example of rule attributes that you can configure:

After you have modified an attribute, the following buttons are displayed in the
Edition actions column of the attribute:

Clicking the button saves the modification to a temporary storage location, not to the
rules file. This means that the rules file itself is not yet modified and code verifications
are still performed with the unmodified rules file.

Clicking the button discards the modifications and resets the attributes to their original
value.

Click SAVE PROJECT to save the modifications to the rules file. Then,
succeeding code verifications will be performed with the modified rules file.

NOTE: If you confirm a modification, this may imply that attributes of a
different rule are also updated. For example, enabling a rule may require
another rule to be activated as well. In such a case, a summary of the
modifications is displayed.

List of the Configuration Attributes
The rules editor allows you to configure the attributes described below. The
meaning of the attributes can vary depending on the rule type. Click the Help tab
to display additional information on an attribute.
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Attribute Description Notes

Enabled Enables/disables a rule. An enabled rule works only if
the parent rule is also enabled.

Certain rules can only be
enabled if further rules are also
enabled in addition to their
parent rules.

Name Name of the rule, visible in the
rules trees, in the rules editor
and in the verification results.

-

Error Message Message displayed if the rule
detects an error.

-

No Match Message Message displayed if the rule
does not detect an error.

This message is displayed only
if no element in the program
can be selected by the rule for
analysis. For example, if the
rule looks for the variables in
the program but no such
variable is declared.

Severity Importance of resolving the
errors reported by the rule.

The severity “nolog” allows you
to suppress the generation of
an error message. However,
the match is still included in the
statistics.

Min Length Minimum length of a verified
element in the program.

The result depends on the rule
type.

Max Length Maximum length of a verified
element in the program.

The result depends on the rule
type.

In addition to these modifiable attributes, two non-modifiable configuration
attributes are displayed: variables and treatments. These two attributes explain
which set of elements in the program the rules are applied to.

Configuration of the Default Rules Files
The default rules files are organized in three main parts (their names depend on
the rules file language and may be different from the names in the present user
guide):

• IAS Generic rules file version X.Y.Z: Contains the controller configuration
(the version number depends on the rules file that you are using)

• Sets definition: Contains several lists of the elements in the controller
application that can be matched by the rules

• Coding rules: Contains the list of rules to be applied
If the objective of the configuration is to modify the controller to be verified with
EcoStruxure Control Engineering - Verification using this rules file, customize the
first part of the rules file (IAS Generic rules file version X.Y.Z). Modifications to
these elements may result in several modifications in the rest of the rules file
because certain rules depend on the controller type and cause the corresponding
rules to be enabled or disabled as well.

If the objective of the configuration is to update the messages, the severity or the
activation state of a particular rule, modify the last part of the rules file containing
the coding rules.

No action is required in the Sets definition part of the rules file.

Adding a Rule
You can add a rule from a pre-defined list of rules and customize this rule. A rule is
added to the location in the rules hierarchy that is selected when you click ADD
RULE.
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Procedure for adding a rule:

Step Action

1 Select a location in the rules hierarchy to specify where the new rule is to be added.

2 Click ADD RULE.

Result: EcoStruxure Control Engineering - Verification displays step 1 of the Rule
Creation Wizard.

3 Select the required rule.

4 Click Validate And Next Step.

Result: EcoStruxure Control Engineering - Verification displays step 2 of the Rule
Creation Wizard.

5 Configure the customizable elements of the rule displayed in step 2 of the Rule
Creation Wizard.

6 Click Validate And Next Step.

Result: EcoStruxure Control Engineering - Verification displays step 3 of the Rule
Creation Wizard.

7 Carefully examine the summary details. To confirm and proceed, click Add Rule. If you
need to make any modifications, click Previous Step to return and adjust your settings.
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NOTE: You can modify the order of your rules with the "Drag and Drop"
function, if needed.

Download a Documentation of a Rules Set
A documentation of a rules set can be downloaded as a PDF file.

To download a documentation of a rules set, click Verification > Rules set >
Download a documentation of the rules set PDF.
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Verification Settings
Select Verification > Settings to open the verification settings for the selected
program.

For each program you can set the following:
• Select a default rules file to be used with the EcoStruxure Control Expert

Plug-In for EcoStruxure Control Engineering - Verification, page 48.
• For invited users of a shared program, page 32:
◦ Enable and disable the possibility to update the rules files.
◦ Enable and disable the possibility to justify the results.

• Enable and disable the Market Insights function for the detailed results.
NOTE: Use the standard rules files provided for the Market Insights,
page 37 function. Modified rules files may lead to less accurate results.
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EcoStruxure Control Expert Plug-In for EcoStruxure
Control Engineering - Verification

General Information
The EcoStruxure Control Expert plug-in for EcoStruxure Control Engineering -
Verification is designed for use with the software development environments
EcoStruxure Control Expert and Unity Pro.

The plug-in allows you to launch a verification procedure from within the software
development environment. The code is automatically exported and uploaded for
verification. The verification results are displayed in a special view in the plug-in. A
“back-to-source” feature in the plug-in allows you to navigate directly to the
corresponding location in the code highlighted by the message.

Compatibility and System Requirements
The EcoStruxure Control Expert plug-in for EcoStruxure Control Engineering -
Verification is compatible with the following versions of EcoStruxure Control
Expert and Unity Pro:

• Unity Pro: From version 8.2 to version 13.1
• EcoStruxure Control Expert: From version 14 to latest supported version

The EcoStruxure Control Expert plug-in requires access to EcoStruxure Control
Engineering - Verification, either in the cloud or on the dedicated server of your
organization.

Download and Installation
The EcoStruxure Control Expert plug-in for EcoStruxure Control Engineering -
Verification is available by clicking SUPPORT > DOWNLOADS.

Follow the instructions during the installation. Compatibility with your software
development environment is verified during the installation.

After the installation, the menu item EcoStruxure Control Engineering -
Verification for EcoStruxure Control Expert is available on the Tools menu:

Program Configuration
The EcoStruxure Control Expert plug-in for EcoStruxure Control Engineering -
Verification requires a program to launch the code verification and return the
results to the plug-in.

The program contains the information on the controller/development environment
that is used to develop the controller application, on the rules file to be used for the
verification, and on the licenses used with EcoStruxure Control Engineering -

48 EIO0000004424.06

Verifying the Code of Controller Applications



Verification. Refer to Program Creation Wizard, page 26 for details on creating
and configuring a program.

Certain licenses for unlimited usage do not require the configuration of a license. If
you do not have an unlimited license, specify your license in step 3 of the program
creation wizard or thereafter select Admin > Licenses > Actions > Associate
new license in the program view.

Refer to Verification Setting, page 47 for details on setting the default rules file and
setting the sharing options.

Share the program key with the collaborators who are to use EcoStruxure Control
Engineering - Verification through the plug-in.

Working with the Plug-In
In EcoStruxure Control Expert, compile your controller application and select
Tools > EcoStruxure Control Engineering - Verification for EcoStruxure
Control Expert.

If you have not assigned the EcoStruxure Control Expert controller application to a
program in EcoStruxure Control Engineering - Verification you are prompted for
the program key:

After you have entered the program key, the plug-in attempts to contact
EcoStruxure Control Engineering - Verification. If you are not authenticated, a new
screen is displayed that allows you to provide a custom proxy configuration. Use
this screen if your organization uses a proxy for outgoing Internet traffic (the
required information to be provided is available from your administrator). After
that, you are prompted for your credentials. You can modify these settings by
selecting ? > Preferences.

The first time you are authenticated, a verification is started. The progress bar at
the bottom of the screen provides details:

The next time you log in, you can start the verification manually by selecting
Actions > Launch analysis.

When the verification is complete, the results are downloaded from EcoStruxure
Control Engineering - Verification and displayed on the plug-in screen.

You can also display the latest results on the EcoStruxure Control Engineering -
Verification server by selecting Actions > Get remote last results. If the results
have already been downloaded to your local PC, you can display them by
selecting Actions > Display local results. The local results may not reflect the
latest results available on the EcoStruxure Control Engineering - Verification
server, for example, because another member of your team has performed a
verification after you have downloaded your results to your local PC.
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The results are displayed in a table:

Columns in this table:
• id: Identifier of the rule that generated the message
• message: Generated message
• severity: Severity of the message (for example, “error” or “info”) as defined in

the rules file
• variable: Name of the variable that matched the applied coding rule
• location: Location in the code where the coding rule is not respected
• address: Topological address of the variable that matched the applied coding

rule
You can jump to the location in your code where the highlighted elements are by
right-clicking a message and selecting Display Data Editor or Display Code
Editor, depending to the kind of the element.

You can set non-conformities as exception and create an appropriate justification
by selecting Justify exceptions…. Refer to Exceptions and Justifications, page
41 for details. You can select multiple messages to be justified in a single step.
However, this is only possible for messages triggered by the same rule.

From within the corresponding tabs in the plug-in, you can also display the rules
file, the program history and list the justifications of the program in EcoStruxure
Control Engineering - Verification.
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Limitations of the Free Trial Version
If the verification has been performed with a free trial license of EcoStruxure
Control Engineering - Verification, the results are limited as shown in the following
list.

Functionality Trial version Paid license

Result details summary Limited No license limitations

Number of messages per
rule

Limited to 2 No license limitations

Rules set visualizer Included Included

Message justifications Included Included

Comparison of results
between program versions

Unavailable Included

Download detailed result as
CSV (for import into
Microsoft Excel)

Unavailable Included

Download detailed result as
PDF

Unavailable Included

Download rules set
documentation as PDF

Unavailable Included

Program versions
comparison as PDF

Unavailable Included

Online rules editor Unavailable Included

Market trends for your
program

Unavailable Included

Market insights in the
detailed results

Limited to median value No license limitations (up to
deciles)

The functions that are not available or limited are highlighted on the Verification
tab of your program:
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• Trial: Limited results
• Unavailable: Function is not accessible
• No indication: No license limitations

You can upgrade to a paid license to get the full functionality of your program.
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Manufacturer-Specific File Export Procedures
EcoStruxure Control Engineering tools use the source code files of controller
applications as input files. These files are exported from the corresponding
software development environments. The following sections provide information
on generating these export files in various software development environments.

EcoStruxure Control Expert (.XEF / .ZEF / .XVM File
Export)

Export the EcoStruxure Control Expert (formerly Unity Pro) controller application
to an XEF, ZEF or XVM export file in order to process them with EcoStruxure
Control Engineering tools.

To export the file, you can use the EcoStruxure Control Engineering Import/Export
tool. In the menu, select SUPPORT > DOWNLOADS.

It is also possible to export the files using the EcoStruxure Control Expert menu:

Step Action

1 From the menu, select File > Export application….

2 In the Export application… dialog box, provide a name for the XEF, ZEF or XVM file.

3 If required, modify the storage location for the XEF, ZEF or XVM file.

4 Click Save.
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EcoStruxure Machine Expert (.EXPORT File Export)
Export the EcoStruxure Machine Expert controller application to an XML export
file (with the extension .export) in order to be processed with EcoStruxure Control
Engineering tools.

Procedure:

Step Action

1 From the menu, select Project > Export….

2 You can export particular objects or a full tree. From the tabs in the Export dialog,
select the objects to be included in the export file.
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Step Action

NOTE: The checkbox One file per subtree allows you to generate separate
export files for the selected subtrees. You can export the file with a specific
EcoStruxure Machine Expert version that you select from the dropdown list
Storage version. To re-import the file, this EcoStruxure Machine Expert version is
used.

3 Click OK and provide a file name and a folder name as prompted.

4 Click Save.
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EcoStruxure Machine Expert Basic (.SMBP File Export)
Export the EcoStruxure Machine Expert Basic controller application to an SMBP
export file in order to be processed with EcoStruxure Control Engineering -
Verification.

Step Action

1 From the menu, select File > Save as….

2 In the Save as… dialog box, provide a name for the SMBP file.

3 If required, modify the storage location.

4 Select the file type: Machine Expert - Basic Project Files (*.smbp).

5 Click Save.
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PL7 Pro (.FEF File Export)
Export the PL7 Pro controller application to an FEF export file in order to be
processed with EcoStruxure Control Engineering tools.

Prerequisites:

Step Action

1 Open the PL7 Pro configuration file Pl7sys.ini using a text editor. The file is located in
the Windows folder (for example, C:\Windows or C:\Winnt).

2 Search for the section [PL7TOOL132].

3 Verify that the entry ExportPl7Converter=True exists.

If the entry does not exist, add the entry in the section [PL7TOOL132].

4 Save the file.

The modification is taken into account with the next start of PL7 Pro.
NOTE: This feature is only available with version 4.5 or later of PL7 Pro.

Procedure:

Step Action

1 From the menu, select File > Export application….

2 In the Export application… dialog box, provide a name for the FEF file.

3 If required, modify the storage location for the FEF file.

4 Click Save.
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3S CODESYS V3 (.EXPORT File Export)
Export the CODESYS V3 controller application to an XML export file (with the
extension .export) in order to be processed with EcoStruxure Control Engineering
tools.

Procedure:

Step Action

1 From the menu, select Project > Export….

2 You can export particular objects or a full tree. From the tabs in the Export dialog,
select the objects to be included in the export file.

NOTE: The checkbox One file per subtree allows you to generate separate
export files for the selected subtrees. You can export the file with a specific
CODESYS version that you select from the dropdown list Storage version. This
version is then used to re-import the file in CODESYS. If you work on CODESYS
V3 code, select a version from the version 3 family (CODESYS V3 …).
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Step Action

3 Click OK.

4 Provide a file name and a folder name as prompted and click Save.
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3S CODESYS V2 (.EXP File Export)
Export the CODESYS V2 controller application to an EXP export file in order to be
processed with EcoStruxure Control Engineering tools.

Step Action

1 From the menu, select Project > Export….

2 In the Export Project dialog box, select the objects to be included in the export file
(with the default settings, a selected item has a blue background), then click OK.
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Step Action

3 Click OK and provide a file name and a folder name as prompted.

4 Click Save.
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BECKHOFF TwinCAT V3 (.XML File Export)
Export the Beckhoff TwinCAT controller application to an XML export file
(PLCopen) in order to be processed with EcoStruxure Control Engineering tools.

Step Action

1 In the Solution Explorer window, select the project.

2 Right-click the project and select Export PLCopenXML….

3 Click Save.
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PHOENIX CONTACT Multiprog v5.5 (.XML File Export)
Export the MULTIPROG controller application to an XML export file in order to be
processed with EcoStruxure Control Engineering tools.

Step Action

1 From the menu, select File > Export….

2 Select Export PLCopen xml file.

3 Provide a name for the export file.

4 Click Save.

As MULTIPROG can export the controller application in different versions of
PLCopen, there may be differences in the way your EcoStruxure Control
Engineering tool processes the export file, depending on the PLCopen version.
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Rockwell Automation® RSLogix 5000® or Studio 5000 (.
L5K File Export)

Export the Rockwell Automation® RSLogix 5000® controller application to a L5K
export file in order to be processed with EcoStruxure Control Engineering tools.

Step Action

1 From the menu, select File > Save as….

2 In the Save as… dialog box, provide a name for the L5K file.

3 If required, modify the storage location.

4 Select the file type: RSLogix 5000 Import/Export File (*.L5K).

5 Click Save.
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Siemens SIMATIC STEP 7 (.ASC, .AWL, .GR7 and .SCL File
Export)

Overview
The following steps are required to process a Siemens SIMATIC STEP 7
controller application with EcoStruxure Control Engineering tools:

• Set your SIMATIC STEP 7 workshop to German abbreviations (mnemonics).
• Create and export the symbols of the controller application to an .ASC file.
• Create and export the contact code (CONT) to an .AWL file.
• Create and export the graph blocks (GRAPH) to .GR7 files.
• Compile the CFC code (if any) to create the corresponding SCL sources.
• Export structural codes (SCL) to .SCL files.

Setting German Mnemonics
Before creating the export files, set your SIMATIC STEP 7 workshop to German
abbreviations (mnemonics):

Step Action

1 From the menu, select Options > Customize….

2 Display the Language tab.

3 Select German mnemonics.

4 Click OK.
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Creating an ASC File

Step Action

1 Right-click the Symbol Table in your program folder and select Open object.

2 From the menu of the Symbol Editor, select Symbol Table > Export….

3 Select ASCII Format (*.ASC).

4 Provide a name and select a directory for the .ASC export file.

5 Click Save.

Creating an AWL File
To create an .AWL file, first generate the LIST source for the code blocks
developed in the languages CONT, LIST and LOG.
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Step Action

1 Right-click a CONT, LIST or LOG source and select Open Object to open the CONT/
LIST/LOG code editor.

2 From the menu, select File > Close to close all open objects.

3 From the menu, select File > Generate source… to generate the program source.

4 Provide an object name and click OK.
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Step Action

5 Click All to select all program blocks and select the options Sort according to
program structure and Symbolic addresses.

6 Click OK to confirm.

If your controller application contains safety-related blocks, export those blocks in
a separate AWL file. Refer to Safety-Related Applications, page 70 for details.

Creating GR7 Files
The .GR7 sources must be created for each GRAPH blocks separately. Repeat
the following procedure for each GRAPH block to be exported.

Step Action

1 Right-click a GRAPH object and select Open Object.

2 From the menu, select File > Generate Source File.
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Step Action

3 Provide a name for the GRAPH object.

4 Click OK to confirm.

5 Repeat the procedure for each GRAPH object to be exported.

Creating a CFG File
The CFG file is required for analyzing the communication and the hardware
configuration of the station.

Step Action

1 Double-click your controller links in the main window to open NetPro.

2 In the NetPro window, double-click the controller of the station to be exported open the
HW Config utility.

3 From the Station menu, select Export… to export your station configuration (leave the
default settings in the dialog box).

Creating a SCL File for CFC Codes
If the controller application contains CFC code, compile the code to generate the
corresponding SCL source file which is the file to be processed with EcoStruxure
Control Engineering tools.
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Step Action

1 Open the CFC code editor by clicking its icon in the toolbar of the main window.

2 Compile the code with the options Entire program and Generate SCL sources and
click OK.

3 The generated SCL source file can then be exported like other source files (refer to
Exporting Files, page 73).

Safety-Related Applications
A safety-related controller application contains two code parts:

• The non-safety-related code part
• The safety-related code part

Procedure for exporting controller applications that contain safety-related code:
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Step Action

1 Export the .ASC file that contains the database for the safety-related code and for the
non-safety-related code (refer to Creating an ASC File, page 66).

2 Generate the sources for the non-safety-related code parts (refer to Creating an AWL
File, page 66 and Creating a GR7 File, page 68).

3 Click All to select all program blocks and select the options Sort according to
program structure and Symbolic addresses.

4 Click OK to confirm.

5 Follow the procedure for Creating an AWL File, page 66 until the dialog box Generate
source Safety is displayed.
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Step Action

6 Select the option User-created F-FBs, F-FCs and F-DBs and click OK to confirm.

7 Create a .dif file (refer to Creating a dif File, page 72). The .dif file is used to determine
whether code is safety-related.

Creating a dif File
A .dif file is created in the SIMATIC Manager of SIMATIC STEP 7 in the following
way:

Step Action

1 From the menu, select Options > Reference Data > Display.

2 In the Display S7 reference data dialog box, select the option regenerated? and click
Yes.
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Step Action

3 In the Customize dialog box, select the option Program Structure and click OK to
display the program structure.

4 From the menu, select View > Export to open the Save dialog box.

5 Provide a name for the .dif and click Save.

Exporting Files
After you have created the files, export them from SIMATIC STEP 7:

Step Action

1 Select the LIST, GRAPH (or .AWL and .GR7 files) and SCL sources that you have
generated.

2 Right-click the sources and select Export source….

3 Select a file name and a storage location and click Save.
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Siemens TIA Portal SIMATIC STEP 7 (.ZIP File Export)
Export the Siemens TIA Portal SIMATIC STEP 7 controller application to a ZIP
export file in order to be processed with EcoStruxure Control Engineering tools.

The export can be performed automatically with the EcoStruxure Control
Engineering - Import/Export tool. Select SUPPORT > DOWNLOADS.

Refer to the EcoStruxure Control Engineering - Import/Export user guide for
details on the export procedure.
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