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Legal Information
The information provided in this document contains general descriptions, technical
characteristics and/or recommendations related to products/solutions.

This document is not intended as a substitute for a detailed study or operational and
site-specific development or schematic plan. It is not to be used for determining
suitability or reliability of the products/solutions for specific user applications. It is the
duty of any such user to perform or have any professional expert of its choice
(integrator, specifier or the like) perform the appropriate and comprehensive risk
analysis, evaluation and testing of the products/solutions with respect to the relevant
specific application or use thereof.

The Schneider Electric brand and any trademarks of Schneider Electric SE and its
subsidiaries referred to in this document are the property of Schneider Electric SE or
its subsidiaries. All other brands may be trademarks of their respective owner.

This document and its content are protected under applicable copyright laws and
provided for informative use only. No part of this document may be reproduced or
transmitted in any form or by any means (electronic, mechanical, photocopying,
recording, or otherwise), for any purpose, without the prior written permission of
Schneider Electric.

Schneider Electric does not grant any right or license for commercial use of the
document or its content, except for a non-exclusive and personal license to consult it
on an "as is" basis.

Schneider Electric reserves the right to make changes or updates with respect to or in
the content of this document or the format thereof, at any time without notice.

To the extent permitted by applicable law, no responsibility or liability is
assumed by Schneider Electric and its subsidiaries for any errors or omissions
in the informational content of this document, as well as any non-intended use
or misuse of the content thereof.
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Safety Information

Important Information
Read these instructions carefully, and look at the equipment to become familiar
with the device before trying to install, operate, service, or maintain it. The
following special messages may appear throughout this documentation or on the
equipment to warn of potential hazards or to call attention to information that
clarifies or simplifies a procedure.

Please Note
Electrical equipment should be installed, operated, serviced, and maintained only
by qualified personnel. No responsibility is assumed by Schneider Electric for any
consequences arising out of the use of this material.

A qualified person is one who has skills and knowledge related to the construction
and operation of electrical equipment and its installation, and has received safety
training to recognize and avoid the hazards involved.

Before You Begin
Do not use this product on machinery lacking effective point-of-operation
guarding. Lack of effective point-of-operation guarding on a machine can result in
serious injury to the operator of that machine.

The addition of this symbol to a “Danger” or “Warning” safety label indicates that an 
electrical hazard exists which will result in personal injury if the instructions are not 
followed.

This is the safety alert symbol. It is used to alert you to potential personal injury 
hazards. Obey all safety messages that follow this symbol to avoid possible injury or 
death.

DANGER indicates a hazardous situation which, if not avoided, will result in death or serious 
injury.

! DANGER

WARNING indicates a hazardous situation which, if not avoided, could result in death or 
serious injury.

WARNING!

CAUTION indicates a hazardous situation which, if not avoided, could result in minor or 
moderate injury.

CAUTION!

NOTICE is used to address practices not related to physical injury.

NOTICE
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WARNING
UNGUARDED EQUIPMENT
• Do not use this software and related automation equipment on equipment

which does not have point-of-operation protection.
• Do not reach into machinery during operation.
Failure to follow these instructions can result in death, serious injury, or
equipment damage.

This automation equipment and related software is used to control a variety of
industrial processes. The type or model of automation equipment suitable for each
application will vary depending on factors such as the control function required,
degree of protection required, production methods, unusual conditions,
government regulations, etc. In some applications, more than one processor may
be required, as when backup redundancy is needed.

Only you, the user, machine builder or system integrator can be aware of all the
conditions and factors present during setup, operation, and maintenance of the
machine and, therefore, can determine the automation equipment and the related
safeties and interlocks which can be properly used. When selecting automation
and control equipment and related software for a particular application, you should
refer to the applicable local and national standards and regulations. The National
Safety Council's Accident Prevention Manual (nationally recognized in the United
States of America) also provides much useful information.

In some applications, such as packaging machinery, additional operator protection
such as point-of-operation guarding must be provided. This is necessary if the
operator's hands and other parts of the body are free to enter the pinch points or
other hazardous areas and serious injury can occur. Software products alone
cannot protect an operator from injury. For this reason the software cannot be
substituted for or take the place of point-of-operation protection.

Ensure that appropriate safeties and mechanical/electrical interlocks related to
point-of-operation protection have been installed and are operational before
placing the equipment into service. All interlocks and safeties related to point-of-
operation protection must be coordinated with the related automation equipment
and software programming.

NOTE: Coordination of safeties and mechanical/electrical interlocks for point-
of-operation protection is outside the scope of the Function Block Library,
System User Guide, or other implementation referenced in this
documentation.

Start-up and Test
Before using electrical control and automation equipment for regular operation
after installation, the system should be given a start-up test by qualified personnel
to verify correct operation of the equipment. It is important that arrangements for
such a check are made and that enough time is allowed to perform complete and
satisfactory testing.

WARNING
EQUIPMENT OPERATION HAZARD
• Verify that all installation and set up procedures have been completed.
• Before operational tests are performed, remove all blocks or other temporary

holding means used for shipment from all component devices.
• Remove tools, meters, and debris from equipment.
Failure to follow these instructions can result in death, serious injury, or
equipment damage.
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Follow all start-up tests recommended in the equipment documentation. Store all
equipment documentation for future references.

Software testing must be done in both simulated and real environments.

Verify that the completed system is free from all short circuits and temporary
grounds that are not installed according to local regulations (according to the
National Electrical Code in the U.S.A, for instance). If high-potential voltage
testing is necessary, follow recommendations in equipment documentation to
prevent accidental equipment damage.

Before energizing equipment:
• Remove tools, meters, and debris from equipment.
• Close the equipment enclosure door.
• Remove all temporary grounds from incoming power lines.
• Perform all start-up tests recommended by the manufacturer.

Operation and Adjustments
The following precautions are from the NEMA Standards Publication ICS 7.1-
1995:

(In case of divergence or contradiction between any translation and the English
original, the original text in the English language will prevail.)

• Regardless of the care exercised in the design and manufacture of equipment
or in the selection and ratings of components, there are hazards that can be
encountered if such equipment is improperly operated.

• It is sometimes possible to misadjust the equipment and thus produce
unsatisfactory or unsafe operation. Always use the manufacturer’s
instructions as a guide for functional adjustments. Personnel who have
access to these adjustments should be familiar with the equipment
manufacturer’s instructions and the machinery used with the electrical
equipment.

• Only those operational adjustments required by the operator should be
accessible to the operator. Access to other controls should be restricted to
prevent unauthorized changes in operating characteristics.
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About the Book

Document Scope
The present user guide describes the functionality provided by EcoStruxure
Control Engineering - Monitoring.

Validity Note
This document has been updated for the release of EcoStruxure Control
Engineering V24.2.

Available Languages of this Document
This document is available in these languages:

• English (EIO0000004427)
• French (EIO0000004775)

Related Documents
Title of documentation Reference number

EcoStruxure Control Engineering -
Documentation - User Guide

EIO0000004426 (eng)

EIO0000004774 (fre)

EcoStruxure Control Engineering - Converter -
User Guide

EIO0000004425 (eng)

EIO0000004773 (fre)

EcoStruxure Control Engineering - Verification -
User Guide

EIO0000004424 (eng)

EIO0000004772 (eng)

Cybersecurity Best Practices CS-Best-Practices-2019-340

EcoStruxure Control Engineering, Hardening
Guide

EIO0000004982 (eng)

To find documents online, visit the Schneider Electric download center
(www.se.com/ww/en/download/).
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Product Related Information

WARNING
LOSS OF CONTROL
• Perform a Failure Mode and Effects Analysis (FMEA), or equivalent risk

analysis, of your application, and apply preventive and detective controls
before implementation.

• Provide a fallback state for undesired control events or sequences.
• Provide separate or redundant control paths wherever required.
• Supply appropriate parameters, particularly for limits.
• Review the implications of transmission delays and take actions to mitigate

them.
• Review the implications of communication link interruptions and take actions

to mitigate them.
• Provide independent paths for control functions (for example, emergency

stop, over-limit conditions, and error conditions) according to your risk
assessment, and applicable codes and regulations.

• Apply local accident prevention and safety regulations and guidelines.1

• Test each implementation of a system for proper operation before placing it
into service.

Failure to follow these instructions can result in death, serious injury, or
equipment damage.

1 For additional information, refer to NEMA ICS 1.1 (latest edition), Safety
Guidelines for the Application, Installation, and Maintenance of Solid State Control
and to NEMA ICS 7.1 (latest edition), Safety Standards for Construction and
Guide for Selection, Installation and Operation of Adjustable-Speed Drive
Systems or their equivalent governing your particular location.

WARNING
UNINTENDED EQUIPMENT OPERATION
• Perform a risk assessment as per ISO 12100 and/or other equivalent

assessment in view of your use of EcoStruxure Control Engineering.
• In your risk assessment, consider all applicable regulations and standards

that apply to your development process and to your machine/process.
• Verify that your use of EcoStruxure Control Engineering is fully covered in

the definition of your software development process and that your software
development process meets all applicable regulations and standards.

• After modifications of any type whatsoever to the source code of your
application resulting from your use of EcoStruxure Control Engineering,
commission or recommission the machine/process in compliance with all
regulations, standards, and process definitions applicable to your machine/
process.

• During commissioning or recommissioning of the machine/process, verify
the correct operation and effectiveness of all safety-related functions and
non-safety-related functions by performing comprehensive tests for all
operating states, for the defined safe state of your machine/process, and for
all potential error situations.

Failure to follow these instructions can result in death, serious injury, or
equipment damage.
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EcoStruxure Control Engineering - Monitoring generates a representation of the
source code of your controller application and uses the representation as a basis
for providing information on your controller application. You must, therefore,
ensure that the source code used for your application on the controller is the same
as the source code used for EcoStruxure Control Engineering. You can do so by,
for example, implementing automated version control routines, or by setting up
appropriate organizational measures to meet the corresponding requirements.

WARNING
INCORRECT OR INCOMPLETE SOURCE CODE ANALYSIS
• In your risk assessment, consider all potential effects of inappropriate,

incorrect, or incomplete input files used with EcoStruxure Control
Engineering.

• Verify that the source code exported from your software development
environment and to be used by EcoStruxure Control Engineering is the
identical to the source code used for the application running on your
controller.

• Do not rely on the data provided by EcoStruxure Control Engineering -
Monitoring as the sole source of information in monitoring, verifying,
validating or otherwise assessing the operation of your machine/process.

Failure to follow these instructions can result in death, serious injury, or
equipment damage.

Machines, controllers, and related equipment are usually integrated into networks.
Unauthorized persons and malware may gain access to the machine as well as to
other devices on the network/fieldbus of the machine and connected networks
because of insufficiently secure access to software and networks.
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Schneider Electric adheres to industry best practices in the development and
implementation of control systems. This includes a "Defense-in-Depth" approach
to secure an Industrial Control System. This approach places the controllers
behind one or more firewalls to restrict access to authorized personnel and
protocols only.

WARNING
UNAUTHENTICATED ACCESS AND SUBSEQUENT UNAUTHORIZED
MACHINE OPERATION
• Evaluate whether your application environments are connected to your

critical infrastructure and, if so, take appropriate steps in terms of prevention,
based on Defense-in-Depth, before connecting the automation system to
any network.

• Limit the number of devices connected to a network to the minimum
necessary.

• Isolate your industrial network from other networks inside your company.
• Protect any network against unintended access by using firewalls, VPN, or

other, proven security measures, such as an Intrusion Prevention System or
Intrusion Detection System.

• Monitor activities within your systems.
• Prevent subject devices from direct access or direct link by unauthorized

parties or unauthenticated actions.
• Install certificates that are issued by publicly known Trusted Certificate

Authorities.
• Keep your systems up-to-date and rely only on legitimate sources.
• Prepare a recovery plan including backup of your system and process

information.
Failure to follow these instructions can result in death, serious injury, or
equipment damage.

For more information on organizational measures and rules covering access to
infrastructures, refer to ISO/IEC 27000 series, Common Criteria for Information
Technology Security Evaluation, ISO/IEC 15408, IEC 62351, ISA/IEC 62443,
NIST Cybersecurity Framework, Information Security Forum - Standard of Good
Practice for Information Security, and refer to Cybersecurity Guidelines for
EcoStruxure Machine Expert, Modicon and PacDrive Controllers and Associated
Equipment.

For reasons of Internet security, for those devices that have a native Ethernet
connection, TCP/IP forwarding is disabled by default. Therefore, you must
manually enable TCP/IP forwarding. However, doing so may expose your network
to possible cyberattacks if you do not take additional measures to protect your
enterprise. In addition, you may be subject to laws and regulations concerning
cybersecurity.

WARNING
UNAUTHENTICATED ACCESS AND SUBSEQUENT NETWORK INTRUSION
• Observe and respect any and all pertinent national, regional and local

cybersecurity and/or personal data laws and regulations when enabling
TCP/IP forwarding on an industrial network.

• Isolate your industrial network from other networks inside your company.
• Protect any network against unintended access by using firewalls, VPN, or

other, proven security measures.
Failure to follow these instructions can result in death, serious injury, or
equipment damage.

Consult the Schneider Electric Cybersecurity Best Practices for additional
information.
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Information on Non-Inclusive or Insensitive Terminology
As a responsible, inclusive company, Schneider Electric is constantly updating its
communications and products that contain non-inclusive or insensitive
terminology. However, despite these efforts, our content may still contain terms
that are deemed inappropriate by some customers.

Terminology Derived from Standards
The technical terms, terminology, symbols and the corresponding descriptions in
the information contained herein, or that appear in or on the products themselves,
are generally derived from the terms or definitions of international standards.

In the area of functional safety systems, drives and general automation, this may
include, but is not limited to, terms such as safety, safety function, safe state, fault,
fault reset, malfunction, failure, error, error message, dangerous, etc.

Among others, these standards include:

Standard Description

IEC 61131-2:2007 Programmable controllers, part 2: Equipment requirements and tests.

ISO 13849-1:2023 Safety of machinery: Safety related parts of control systems.

General principles for design.

EN 61496-1:2013 Safety of machinery: Electro-sensitive protective equipment.

Part 1: General requirements and tests.

ISO 12100:2010 Safety of machinery - General principles for design - Risk assessment
and risk reduction

EN 60204-1:2006 Safety of machinery - Electrical equipment of machines - Part 1: General
requirements

ISO 14119:2013 Safety of machinery - Interlocking devices associated with guards -
Principles for design and selection

ISO 13850:2015 Safety of machinery - Emergency stop - Principles for design

IEC 62061:2021 Safety of machinery - Functional safety of safety-related electrical,
electronic, and electronic programmable control systems

IEC 61508-1:2010 Functional safety of electrical/electronic/programmable electronic safety-
related systems: General requirements.

IEC 61508-2:2010 Functional safety of electrical/electronic/programmable electronic safety-
related systems: Requirements for electrical/electronic/programmable
electronic safety-related systems.

IEC 61508-3:2010 Functional safety of electrical/electronic/programmable electronic safety-
related systems: Software requirements.

IEC 61784-3:2021 Industrial communication networks - Profiles - Part 3: Functional safety
fieldbuses - General rules and profile definitions.

2006/42/EC Machinery Directive

2014/30/EU Electromagnetic Compatibility Directive

2014/35/EU Low Voltage Directive

In addition, terms used in the present document may tangentially be used as they
are derived from other standards such as:

Standard Description

IEC 60034 series Rotating electrical machines

IEC 61800 series Adjustable speed electrical power drive systems

IEC 61158 series Digital data communications for measurement and control – Fieldbus for
use in industrial control systems
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Finally, the term zone of operation may be used in conjunction with the description
of specific hazards, and is defined as it is for a hazard zone or danger zone in the
Machinery Directive (2006/42/EC) and ISO 12100:2010.

NOTE: The aforementioned standards may or may not apply to the specific
products cited in the present documentation. For more information concerning
the individual standards applicable to the products described herein, see the
characteristics tables for those product references.
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Introduction to EcoStruxure Control Engineering -
Monitoring

Overview
EcoStruxure Control Engineering - Monitoring is a diagnostics solution that
provides live views of your running controller application to help reduce the
downtime of controller-based systems by supporting operators and maintenance
teams in diagnosing an issue.

It provides a representation of the structure of your controller application in the
form of a data flow dependence tree with the corresponding cross-references (in
Ladder or Structured Text) that show the different equations relating to a selected
variable. Based on these dependence tree and cross-reference representations,
EcoStruxure Control Engineering - Monitoring displays the values of the variables
of the running controller application. Views are available that show only those
inputs that are instrumental in determining the values of a selected output, or only
the outputs whose values depend on a selected input.

EcoStruxure Control Engineering - Monitoring is installed on a dedicated server in
your industrial production network. It is a Software as a Service (SaaS) tool
accessible using a web browser. This allows, for example, for access from
distributed locations, enabling on-site maintenance staff to be supported by
engineers who are not on site.

Use Cases
EcoStruxure Control Engineering - Monitoring meets the requirements of different
profiles in various use cases:

• Operators:
◦ Assistance in determining potential causes for machine downtime
◦ Support in securing the system before a restart

• Maintenance teams:
◦ Diagnostics of hardware issues
◦ Diagnostics of software issues
◦ Identification of missing criteria

• Automation experts/developers:
◦ Familiarization with complex systems
◦ Reduction of the time required to develop the monitoring system by

removing the need to create diagnostic synoptics (EcoStruxure Control
Engineering - Monitoring can substitute corresponding panels).

◦ Reduction of the time required for code instrumentation since EcoStruxure
Control Engineering - Monitoring does not require any.

For each of these profiles, EcoStruxure Control Engineering - Monitoring is also
useful for training people.

14 EIO0000004427.05
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Registration, Login, Account Settings, Licenses and
Sessions

Registration

Overview
The EcoStruxure Control Engineering tools are accessible using a dedicated
server for your organization.

The URL of the dedicated server is available from your system administrator.

Browser Compatibility
The following web browsers are supported:

• Mozilla Firefox from version 102
• Google Chrome from version 127
• Microsoft Edge from version 127
• Apple Safari from version 17

Registration
Contact your system administrator to coordinate the registration before you begin
the registration procedure.

Registration procedure:

Step Action

1 In your browser, go to the URL of the dedicated server.

2 Click Sign up.

3 Fill in the form with your first and last names, your phone number, your email address
(which is used as your identifier) and select a password. Password requirements:

• At least one uppercase character
• At least one lowercase character
• At least one numerical character
• At least one special character (such as ”{”, ”/”, “$” )
• Password length at least eight characters

4 Read the Terms and Conditions and, if you agree, select I agree to the Terms and
Conditions.

5 Click Sign Up.

Result: Your account is created and activated.
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Login
Login procedure:

Step Action

1 In your browser, go to the URL of the dedicated server.

2 Enter your email address and password.

3 Click Login.

Result: After validation, you are redirected to your dashboard.

16 EIO0000004427.05
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Account Settings
The Settings page helps you to access the personal information of the account
and the global EcoStruxure Control Engineering platform settings.

Step Action

1

In the Dashboard window, click .

Result: A menu is displayed.

2 Click Settings.

Result: The Settings page is displayed.

The Profile tab lists the user personal information such as the identity, phone
number and country. You can update this information at any time.

The Password tab provides the password change form. You can change your
password at any time.

The Notifications tab allows you to configure the type of email notifications sent
to you by the web platform.

The View Settings tab allows you to select the default view for projects.

The Accessibility tab allows you to adapt the on-screen representation to your
personal needs, for example, high contrast colors.

The Privacy tab provides general information on privacy and on the cookies
policy. It describes how personal data is used and how you can exercise your
rights relating to personal data.

You can receive email notifications and delete the personal information if the
dedicated server is configured to send the emails.

EIO0000004427.05 17
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Licenses

General
Schneider Electric offers various license plans for EcoStruxure Control
Engineering tools.

Paid License Plans
Contact your local Schneider Electric representative for details on the available
license plans for EcoStruxure Control Engineering tools. A selection of licenses is
also directly available from Schneider Electric Software Shop Catalog at https://
www.se.com/us/en/shop/software/?offerid=ECEE.

Overview of Your Paid Licenses, Your Orders And Your Contract
In the main menu click LICENSES & ORDERS to get an overview of your paid
licenses, your orders and your contract.

The overview contains three tabs:
• The Licenses tab contains a list of your available licenses.
• The Orders tab contains a list of your orders.
• The Contract tab contains details of your contract.

Licenses Tab
The Licenses tab contains a list of licenses associated with your account. The list
contains information such as license ID, name and type.

The buttons Buy New Licenses On Schneider Electric Software Shop (cloud
version) and Order Licenses (dedicated server version) allows you to buy
additional licenses.

• If you use the cloud version, the Buy New Licenses On Schneider Electric
Software Shop button opens the Schneider Electric Software Shop Catalog
(https://www.se.com/us/en/shop/software/?offerid=ECEE). After the checkout
process, your licenses are automatically added to your account (within
approximately 30 minutes).

• If you use the dedicated server version, the Order Licenses button opens a
wizard. With the wizard you can add the licenses you want to buy. At the end
of the wizard you must download the license request file and send it to your
Schneider Electric service representative. The Schneider Electric service
representative sends you then a license file. You must install the license file
manually using the Install Licenses button.

The Quick Filters button allows you to filter your licenses. The licenses can be
filtered by logic controller brand or by expiration date (licenses that expire within
the next three weeks).

The Transfer Licenses button allows you to transfer one or more licenses to a
different user. A license can only be transferred if the license has not yet been
used, has not expired and is not currently associated to a program.

Orders Tab
The Orders tab contains a list of orders associated with your account. The list
contains information such as name, status and description.
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The details of an order can be displayed by clicking the name of an order.

Information for each order:
• The Overview tab shows details on the person who created the order and the

state of the order.
• The Order content tab shows details on the ordered products.
• The Licenses tab shows a list of the associated licenses.

If you use the dedicated server version, this tab allows you to download once
again the license request file for orders created via the wizard.

Contract Tab
The Contract tab contains details of your contract. A contract allows you to
provide seat licenses for a group of users and to set default Glips versions.

The Summary button provides a summary of your contract (contract name,
description, contract manager, company and subscribed products) and a list of the
members of the contract.

The Repository button shows a list of files that are shared between the contract
members, for example, the rules file.

As a contract manager, you can do the following:
• The buttons Reporting > Activity summary and Reporting > History show

usage statistics of the contract members.
• The Administrate > Contract members button allows you to add and

remove contract members.
• The Administrate > Default Glips versions button allows you to set the

default Glips version for each use case. Verify that the Glips version you
select meets your requirements and matches the specifics of the input code.
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Sessions

Automatic Log-Out (Session Time-Out)
After 11 minutes of inactivity in an EcoStruxure Control Engineering session, you
are automatically logged out. If you work with multiple browser tabs, the most
recent activity in any of the tabs applies. For example, if you work in tab 1, but not
in tab 2, tab 2 does not disconnect you because there is activity in tab 1.

Multiple Sessions
If your credentials are used in multiple sessions, you receive a notification. For
example, if you are logged in and another session is established with the same
credentials, you receive the following message:

The information on the connection date and time, the IP address, the operating
system and the browser help you to determine whether or not a session is
legitimate. You can select and close a session with Close Session(s).
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Creating Projects and Programs

Introduction to Projects and Programs

Overview
EcoStruxure Control Engineering provides projects and programs for you to
organize your work.

A project is a type of container that can hold programs. A project is not specific to
an EcoStruxure Control Engineering tool.

When you register with EcoStruxure Control Engineering, the platform provides
one default project for you.

A program is assigned to a project. A program is created in conjunction with one of
the tools provided by EcoStruxure Control Engineering. A program typically
comprises metadata you entered during its creation, the uploaded source code of
a controller application, and the results generated with the EcoStruxure Control
Engineering tools.

The EcoStruxure Control Engineering tools are launched from within a program.
Whether or not a specific EcoStruxure Control Engineering tool is available for a
program depends on the source controller/development environment you select
during the creation of the program (PLC Brand or PLC source brand).

Programs can be shared with other users.

Example
Assume you have been assigned the task of improving a machine ABC with two
controllers X and Y. In a first step, you want a deeper understanding of the code of
the two controller applications. You create a project “Machine ABC”. Then you add
two programs to this project: “Controller X” and “Controller Y”.

In both of these programs, you run EcoStruxure Control Engineering -
Documentation to visualize the data flow and the control flow.

In the next phase, you manage the creation of a new version of the controller
applications with improved quality. You start by running EcoStruxure Control
Engineering - Verification in your programs to verify the existing code. You share
the two programs with the developers so they can access the results of the code
verification for assistance in updating the code.

In subsequent phases, you can upload intermediate versions of the updated code
into your program and re-run EcoStruxure Control Engineering - Documentation
and EcoStruxure Control Engineering - Verification to document the progress and
verify that your coding rules have been properly implemented.

EIO0000004427.05 21

Creating Projects and Programs



Creating Projects and Programs

Creating Projects
Procedure for creating a project:

Step Action

1 Select PROJECTS in the top menu to display the Projects page.

2 Select Actions > New project.

3 Provide a unique name for your project. Lowercase and uppercase are ignored which
means that, for example, the name of a project to be created cannot be “Controller xyz”
if you already have a project with the name “Controller XYZ”.

4 Click Add to create the project.

Result: The project is added to your list of projects on the Open projects tab.

Clicking a project in the list displays three tabs. The Overview tab provides
general information on the project. The Programs tab contains the list of
programs assigned to this project. The Settings tab contains the project settings.

Creating Programs
There are three ways to start the creation of a program:

• From outside of a project select TOOLS on the main menu
• From the dashboard click New ...
• From inside a project on its Programs tab select Actions > New program
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Creating a program from outside of a project:

Step Action

1 From the main menu, select TOOLS to display a list of the available tools.

2 Select the tool you want to use for the program.

Result: EcoStruxure Control Engineering starts the program creation wizard.

Creating a program from the dashboard:

Step Action

1 From the main menu, select DASHBOARD.

2 Click the New ... button for the tool you want to use for the program.

Result: EcoStruxure Control Engineering starts the program creation wizard.

Creating a program from inside a project:

Step Action

1 From the main menu, select PROJECTS.

2 Select the required project from the list.

3 Display the Programs tab of the project.

4 Select Actions > New program.

Result: EcoStruxure Control Engineering prompts you for the tool to be used for the
program and starts the program creation wizard.
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Program Creation Wizard

Overview
A wizard guides you through the different steps required to create your program
and launch the selected EcoStruxure Control Engineering tool.

The project to which the new program is assigned depends on how the wizard is
started. If the wizard is started from outside of a project or from the dashboard, the
program is assigned to your default project. If the wizard is started from inside a
project, the program is assigned to this project. In both cases, the project
assignment can be adjusted in step 1 of the wizard.

Refer to Creating Programs, page 22 for details.

Step 1 - Start
The first step consists of providing setup information on the program.

Provide the following information:
• The fields Application name and Customer name are mandatory. The

defined Application name is used to identify the program in the different
views of EcoStruxure Control Engineering.

• For Monitoring, the PLC reference field is required to configure the
connection with the OPC server.

• Add additional information in the other fields so that you can identify this
program in your project.

Continue with the next step by clicking Validate And Next Step.

Step 2 - Parameters
The second step consists of selecting the development environment that was
used to develop the controller application.
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Select the PLC brand and continue with the next step by clicking Validate And
Next Step.

Step 3 - License
The third step consists of selecting the EcoStruxure Control Engineering license to
be used with your new program.

Choose one of the Licensing possibilities for this program:

Licensing possibilities Description

Do not assign a license now Select this option when you will not run the analysis
immediately.

Use a license ID Select this option when you have a license code. If you have
a license, but the license has not yet been assigned to your
user account, you can still use it by entering its identifier in
the License #id field.

Use a free trial license Select this option to launch a trial version of the tool. This is
not possible if you have already used all trial licenses that
have been associated with your user account.

Use a contract license This option becomes available when you have a contract for
EcoStruxure Control Engineering. This allows you to
automatically generate a license, as part of your contract, to
run the analysis.

Use an account license This option becomes available when licenses are available
in your account. In this case, you can select the license from
a dropdown list.

Click Validate And Next Step to continue.

If no license is available, you can still continue creating the program by clicking
Validate And Next Step. In this case, a license can be added to the program after
you have created the program. Without a valid license, the EcoStruxure Control
Engineering tool selected for this program cannot be used.

Step 4 - Source file
The fourth step consists of uploading the file with the source code of the controller
application that you have exported from the development environment (refer to
Manufacturer-Specific File Export Procedures, page 51 for details). This source
code is the input material for EcoStruxure Control Engineering. Depending on the
EcoStruxure Control Engineering tool used for the program, you may be prompted
to upload additional files.
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Drag and drop the files to the location indicated or click Select Files… to import
the files.

Unwanted files can be removed with the garbage can symbol.

Then click Validate And Next Step to continue.

If the input files are not yet available when you create the program, you can skip
the upload with Validate And Next Step and provide the files at a later point in
time. Without the uploaded input files, the EcoStruxure Control Engineering tool
selected for this program cannot be used.

Step 5 - Summary
The fifth step displays a summary of the information you have provided in creating
your program.

Review the information. If you want to make modifications, click Previous Step to
return to the step you want to modify.

If the information is correct, click Create Without Executing to create the
program or click Create And Execute to create the program and to start the
EcoStruxure Control Engineering tool selected for this program (this is possible if
you have selected a valid license and if you have uploaded the required files).
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Overview of the Program

General Information
After you have completed the wizard, the system displays an overview of the
program with the following tabs:

• Overview tab
• Tool-specific tab
• Admin tab

Overview Tab
The Overview tab displays program-specific information, such as creation date
and controller-related information.

The Glips version determines the way the code is interpreted.

The default Glips version for each program is either set by the system or, if you
are a Contract Member, by your Contract Manager.

You can modify the Glips version to be used for your program. This implies that
the results that you receive after a modification of the Glips version may be
different. Verify that the Glips version you select meets your requirements and
matches the specifics of the input code.

Tool-Specific Tab
The tool-specific tab allows you to access settings and results related to the tool
used for the program.

The menu <tool-specific> > User awareness > Execution messages allows
you to access the list of categorized messages regarding errors detected while
using the tool.

Admin Tab
The Admin tab allows you to access settings specific to the program.
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Accessing a Shared Program
If a program is shared with you, or if access to the program is not restricted (refer
to Sharing a Program, page 29), you can add it to your list of programs by
providing its unique program key. The unique program key can be found in the
program overview under Program key.

Procedure for adding a program to your list of programs:

Step Action

1 From the main menu, select PROJECTS to access the Projects page.

2 Click Shared programs to display the corresponding tab.

3 Enter the unique program key in the Add To My Programs field if you want to add this
program to your personal records for access at a later point in time.

If you only want to access it once without adding it to your list of programs, enter the
program key in the One Time Access field.

4 Click Add To My Programs or One Time Access, depending on the field in which you
entered the program key.
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Sharing Programs with Other Users

Overview
You can share your programs with other users so that a team can work on the
same project. As the owner, you can share your program. Selected users with
whom you share your program cannot delegate their access rights, that is, they
cannot share this shared program with further users.

In sharing programs, consider confidentiality rules that may apply.

There are two ways of sharing a program:
• Share with selected users: You choose who can access your program. By

default, other users cannot share this program because you are the owner.
• Share with everyone: Everyone can access your program.

Sharing with a Specific User
Procedure for sharing a program with selected users:

Step Action

1 Navigate to the Program page.

2 Select Admin > Collaboration > Users access rights to display the User
management.

3 Below Invited collaborators, select Actions > Add .

4 Enter the email address of the user to be invited. You can enter the email address the
user specified for registration with EcoStruxure Control Engineering, or you can use
any other email address. You can also send an invitation notification to the user. On a
dedicated server, the invitation notification function requires an email server.

Users added to the list of invited users can perform the same actions as you, except for
sharing the program and modifying its settings. If you do not want invited users to
perform any further actions, deactivate the program with the Active program checkbox
in Admin > Settings. This sets your program to read-only.

NOTE: If your program uses the EcoStruxure Control Engineering -
Verification tool, invited users may not be able to update the rules file and may
not be able to work with the Justifications function. Refer to the EcoStruxure
Control Engineering - Verification user guide for details.

You can revoke sharing by selecting the user account(s) you want to remove from
your program and selecting Actions > Remove access.

Sharing with Everyone
Procedure for sharing a program with everyone:
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Step Action

1 Navigate to the Program page.

2 Select Admin > Settings.

3 Deactivate the checkbox Private program.

Users accessing your program can perform the same actions as you, except for sharing
the program and modifying its settings. If you do not want invited users to perform any
further actions, deactivate the program with the Active program checkbox in Admin >
Settings. This sets your program to read-only.

NOTE: If your program uses the EcoStruxure Control Engineering -
Verification tool, invited users may not be able to update the rules file and may
not be able to work with the Justifications function. Refer to the EcoStruxure
Control Engineering - Verification user guide for details.

You can disable sharing with everybody by activating the checkbox Private
program. With this setting, only users explicitly invited can access your program.
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File Repository of Programs

General
Each program has a file repository. You can directly access the files belonging to a
program via the file repository.

File Operations
The Actions menu contains the following menu items:

Menu item Description

Add file You can add additional files to the repository.

Add file synchronized
with contract

You can add links to files contained in the contract repository which are
then available in your program repository. Any subsequent modifications
to such linked files in the contract repository are reflected in your
program repository.

Rename file You can rename a file in the repository.

Delete You can delete one or several files from the repository.

Get Checksum You can display the SHA256 checksum of one or several files in the
repository.

Use the following Windows PowerShell command to compute the
checksum of your local file:
Get-FileHash <Path to the file> -Algorithm SHA256 |
Format-List

The result is, for example:
Get-FileHash C:\Users\SE\Downloads\rulesset_
documentation.pdf -Algorithm SHA256 | Format-List

Algorithm : SHA256
Hash :
A5978FECDBE98C2C9C6479328AB2F717EBC239C9DA59-
D55015AD3D5D50C63750
Path : C:\Users\SE\Downloads\rulesset_
documentation.pdf

The Download Repository (ZIP) button lets you download the files contained in
the repository as a single zip file.
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Monitoring a Controller Application

Pre-Deployment Considerations

Overview
EcoStruxure Control Engineering - Monitoring complements the controller
commands for diagnostics.

EcoStruxure Control Engineering - Monitoring does not affect the commands of
the controller application for your production process, but provides information on
the status of such commands to support you in, for example, resolving issues that
may cause machine downtime.

Pre-Requisites Regarding the Controller Application
The quality of the analysis of the source code of controller applications largely
depends on the quality of such code. Using consistent coding rules and standards
enables a better comprehension of what the source code does or is intended to
do. Analyzing tools that respect a set of coding rules facilitates and improves the
quality of diagnostics. For example, if the names of variables are explicit and have
a clear comment, it is much easier to understand the role of the variables.

The architecture of a controller application also plays an important role in the
analysis of the code. A controller application containing many pointers is more
difficult to diagnose than a controller application without pointers.

If you are unsure about the quality or suitability of your controller application for
use with EcoStruxure Control Engineering - Monitoring, verify the source code
with EcoStruxure Control Engineering - Verification to identify optimization
potential before using EcoStruxure Control Engineering - Monitoring.
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Architecture

Overview
The following descriptions provide a generic overview of the architecture of an
EcoStruxure Control Engineering - Monitoring solution. The actual architecture
and configuration depend on your specific hardware and software environment
and the corresponding requirements.

Web Platform
The web platform manages the analysis of the controller application in order to
generate the data flow information. It is also from the web platform that
EcoStruxure Control Engineering - Monitoring can be launched and the results
can be visualized.

The web platform is available using a client workstation with a web browser.

Communication Server (COM Server)
The communication server is a Web Socket server allowing for communication of
process data (that is, direct communication with the controller systems or with an
OPC server). This component can be installed on a virtual machine (VM) or on a
separate server. The data is obtained from the controller system either with the
Modbus TCP protocol or with the OPC-DA protocol (using an OPC server). The
possible configurations for the installation of these components are described
below.

Your IT department needs to open certain ports and provide the appropriate
permissions in your network to allow for communication with the controller
systems or the OPC server.

Communication using OPC Server
The communication server is installed on the same virtual machine as the web
platform and uses an OPC-DA connection to communicate with the OPC server.
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In order to provide you with valid data, the communication server requires a valid
configuration of the OPC-DA server, especially if the requests use names of
variables instead of addresses.

Communication using OPC Server and Communication Server
To account for certain configuration constraints, the communication server can be
installed on the same computer as the OPC server you use.

Direct Communication using Modbus TCP
The communication server uses the Modbus TCP protocol for direct
communication with the controller system.
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Installation and Configuration

Package
EcoStruxure Control Engineering - Monitoring is provided in a virtual machine
(VM) that contains the environment required for its operation. It includes the
communication server in charge of the communication between EcoStruxure
Control Engineering - Monitoring and your controller application (if you enable
OPC communication from the virtual machine). The communication server can
also be installed on your server (physical machine) that hosts the OPC server
(according to your cybersecurity policies).

Installation of the Virtual Machine
EcoStruxure Control Engineering - Monitoring is delivered in the form of a virtual
machine that virtualizes a Linux Debian operating system.

This virtual machine can be delivered on different architectures and hypervisors:
• VMware that can be used on its OS ESX server, or on Windows
• Hyper-V (Microsoft)
• Oracle VM VirtualBox (Oracle)

Contact your Schneider Electric representative for other hypervisors and
architectures.

For more information on cybersecurity guidelines, refer to EcoStruxure Control
Engineering Cybersecurity, Hardening Guide.

Installation of the Communication Server
The communication server component is installed like a Windows service. The
installation procedure is explained below for Microsoft Windows. The following
operating systems are supported:

• Microsoft Windows 10
• Debian Linux 9 and 10

Configuration
The configuration is adapted in the file config.properties which is located in the
root of the folder containing the service wrapper:
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Property Example Description

dataProviderType 1 (for Modbus TCP) Defines the protocol to be used
for the installation. OPC DA
and Modbus TCP are
supported.

dataProviderADDR 127.0.0.1 when it is installed
on the same computer as the
communication server.

Primarily used for OPC DA
communication. This is the IP
address of the computer on
which the OPC server is
installed.

dataProviderPort 103 for OPC Server and 502
for Modbus TCP

The port used by the OPC
Server or by Modbus TCP.

dataProviderUser - Only for OPC DA. This is the
name of the system user who
has access to the computer on
which the OPC server is
installed.

dataProviderPassword - Only for OPC DA. This is the
password of the system user
who has access to the
computer on which the OPC
server is installed.

dataProviderDomain WORKGROUP Only for OPC DA. This is the
domain name of the computer
on which the OPC server is
installed.

dataProviderProgId - Only for OPC DA. This is the
program ID of the OPC server.

dataProviderClsId - Only for OPC DA. This is the
CLS ID of the OPC server.

updateRate 5000 ms (default value) The time interval to refresh the
values of variable. With OPC
DA communication, the
communication server
refreshes the values of the
variables every five seconds.

NOTE: Verify that your
infrastructure supports the
value specified.

NOTE: Restart the server service after each modification to the configuration
(for example, using the Windows services management console).

Installation of the EcoStruxure Control Engineering - Monitoring
Service of the Communication Server

The service wrapper can be installed by executing the script for the corresponding
Windows version:

• Windows 32 bit: windows-x86-32\installService.bat
• Windows 64 bit: windows-64/installService.bat

After the installation procedure, a command prompt with the installation status
message is displayed (successful or not successful). The service is enabled
following a successful installation.

36 EIO0000004427.05

Monitoring a Controller Application



It is possible to verify the status of the service by executing the file windows-x86-
32\ICSMonitoring.exe. A window is displayed that allows you to stop or launch
the service and to view the logs and service properties. It is advisable to keep
automatic startup.

NOTE: The storage location of the installation package is used as the
installation location, that is, the program is not installed in the Windows
\Program Files tree, but in the directory in which the installation package is
contained.

Integration With a Supervision System
Supervision software capable of opening a web browser directly within the window
or as an external software can integrate EcoStruxure Control Engineering -
Monitoring. You can integrate EcoStruxure Control Engineering - Monitoring into
your supervision system either by automating the generation of the opening action
from a variable or an alarm, or by adding an action button to launch it for the
corresponding software (for example, in Visual Studio, the WebBrowser class
defined in System.Windows.Forms can be used to open a web browser window).

Integration With a Version Control System
EcoStruxure Control Engineering - Monitoring generates a representation of the
source code of your controller application and uses the representation as a basis
for providing information on your controller application. You must, therefore,
ensure that the source code used for your application on the controller is the same
as the source code used for EcoStruxure Control Engineering. You can do so by,
for example, implementing automated version control routines, or by setting up
appropriate organizational measures to meet the corresponding requirements.

WARNING
INCORRECT OR INCOMPLETE SOURCE CODE ANALYSIS
• In your risk assessment, consider all potential effects of inappropriate,

incorrect, or incomplete input files used with EcoStruxure Control
Engineering.

• Verify that the source code exported from your software development
environment and to be used by EcoStruxure Control Engineering is the
identical to the source code used for the application running on your
controller.

• Do not rely on the data provided by EcoStruxure Control Engineering -
Monitoring as the sole source of information in monitoring, verifying,
validating or otherwise assessing the operation of your machine/process.

Failure to follow these instructions can result in death, serious injury, or
equipment damage.
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Integrating EcoStruxure Control Engineering - Monitoring and a version control
system facilitates keeping the controller application used for EcoStruxure Control
Engineering - Monitoring and the controller application used to run your system
synchronized. After each modification to your controller application and the
deployment of this controller application in your system, the following steps are
required:

Step Action

1 Exporting the code of the controller application in the corresponding format with the
help of the EcoStruxure Control Engineering - Import/Export tool.

2 Launching the EcoStruxure Control Engineering - Monitoring program on the newly
uploaded version of the code of the controller application.

These two steps can be executed automatically without user intervention. This is
managed by script mechanisms (such as hooks) that are available in version
control tools.

NOTE: Verify that EcoStruxure Control Engineering - Monitoring has access to
both the archived controller applications and the data from the production
systems.
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Creating a Representation of an Controller Application

Procedure
No tool can provide analysis procedures for all potential types of code and
methods of creating code. For example, a code block in your source code may be
semantically invalid, but syntactically correct. The tool may not be able to detect
such a condition.

Software development environments may provide code protection features
intended to, for example, block access to intellectual property. Unlock such
protected code blocks in your software development environment before creating
export files to be used with EcoStruxure Control Engineering.

WARNING
INCORRECT OR INCOMPLETE SOURCE CODE ANALYSIS
• In your risk assessment, consider all potential effects of inappropriate,

incorrect, or incomplete input files used with EcoStruxure Control
Engineering.

• Verify that the source code exported from your software development
environment and to be used by EcoStruxure Control Engineering is complete
and up to date.

• After modifications of any type whatsoever to the source code of your
application resulting from your use of EcoStruxure Control Engineering,
verify the correctness of the modified source code.

Failure to follow these instructions can result in death, serious injury, or
equipment damage.

Step Action

1 Select Documentation | Monitoring > Launch Monitoring on the Program page.

2 Upload the source files of the controller application exported from your software
development environment as described in Program Creation Wizard, page 24.

3 Specify the files to be analyzed. If you do not want to generate the representation for
each file, you can remove unwanted files by unselecting them in the list.

4 Start the representation process by clicking Launch.
NOTE: The time required to generate your representation depends on the size and
complexity of the source code of the controller application. Progress information is
displayed on the Program page.
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The Data Flow View

General
The Data Flow view displays the relationships between variables of a controller
application from input to output, or vice versa.

This view displays how the values of the variables of the controller application are
read or written.

Displaying the Data Flow View
To display the Data Flow view, select Monitoring > Data flow.

NOTE: If you have downloaded a copy of the online results and want to work
with the downloaded copy, open the index.html file and click the Display
Data Flow button. Refer to Downloading an Offline Version of the
Representation, page 50.

Overview of the Data Flow View
The Data Flow view consists of four parts:

• List of variables to explore and settings for variables (top left, green frame)
• Dependency tree (bottom left, purple frame)
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• Language settings (top right, blue frame)
• Cross-references snippets (bottom right, yellow frame)

List of Variables
The list of variables to explore lets you select a variable whose dependencies you
want to display. Click List Of Variables to select a variable.

Functions for finding a variable:
• You can scroll through the list using the page buttons at the bottom of the

view. You can specify the number of variables to be displayed on a single
page using the dropdown list at the top left part of the table.

• You can filter the variables using the search field at the top right part of the
list. You can search by full or partial name, address and comment of a
variable.

Click the name of a variable to display it in the dependency tree and in the cross-
references snippets parts of the page.

The Data flow direction lets you specify the way the dependencies are listed and
displayed. Write displays only the dependencies that write the value of the
variable. Read displays only the variables that are used to write to other variables
that are using the selected variable. Read and write displays both. This selection
also affects the way the dependency tree is displayed.

Dependency Tree
The dependency tree is a graphical representation of the dependencies between
the variables. If a variable is used to compute or to determine another value, this
variable is displayed with a link to that other variable.
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In the example above, the following is true of the selected (blue) variable (Data
flow direction is set to Read and write):

• The variable needs the values of the two linked variables displayed to its left
in order to calculate its own value.

• The variable is used to calculate the values of the linked variables displayed
to its right.

You can explore the relationships between variables by clicking their names.

This view is helpful to locate the variables affected if code is modified in the
controller application, or to determine an unwanted value of a variable in the
running controller application.

Language Settings
The language settings let you select Ladder or Literal as the language for the
cross-references snippets.

Depending on the different types of variables, a representation of the code in
Ladder may not be available. In such a case, the cross references snippets are
displayed in Literal.

Creating a flow chart from an controller application is a complex operation.
Depending on the complexity of the code and the different types of objects,
EcoStruxure Control Engineering - Monitoring may not be able to generate a
precise flow if a variable is indexed and/or if its address is accessed indirectly
using a variable in the controller application.

Cross-References Snippets
The cross-references snippets part of the page displays how the variables are
used in the calculations of one another.

It consists of a code extract (displayed in Ladder or Literal language) that
highlights the relations. The code extract is not displayed in the same way it is
written in the original code in order to provide a synthetic view. Its logic still
remains the same as in the original code. The logic can be retrieved using the
location displayed above each snippet.

For instance, if you access a variable inside several nested conditional
instructions, the snippet compresses these instructions into a single one.
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The cross-references snippets view is updated each time you select a variable
either in the list of variables or in the dependency tree.

Live Visualization
EcoStruxure Control Engineering - Monitoring provides a live visualization of the
values of the variables of the running controller application. The transmission
latency between the running controller application and the visualization in
EcoStruxure Control Engineering - Monitoring depends on, among other things,
the communication infrastructure, the server settings (refer to updateRate in
Configuration), and the controller application itself.

To start the live visualization, click Start under Monitoring.

NOTE: The Test Connection button allows you to test the connection, for
example, in order to test whether the view is frozen or the communication
server is running.

The states of a variable are displayed depending on the type and the value:
• Boolean value: If the value is TRUE, the node is green. If the value is FALSE,

the node is red.
• Non-boolean value: The value is displayed in a label associated with the

node.
• Indeterminable: The “?” symbol is displayed next to the node if the value

cannot be retrieved because it does not have an address or is not accessible.

In the following example, the value of the variable robot_running depends on the
value of the variable Start_process and determines the values of the variables
Rotation_left and init.
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Representation in the dependency view:

Representation in Ladder language:

Representation in Literal language:
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The Control Flow View

General
The Control Flow view displays the order in which the function calls or procedure
calls are executed or evaluated.

This view displays the way the logic of the controller application is called.

Displaying the Control Flow View
Select Monitoring > Control flow.

NOTE: If you have downloaded a copy of the online results and want to work
with the downloaded copy, open the index.html file and click the Display
Control Flow button. Refer to Downloading an Offline Version of the
Representation, page 50.
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Overview of the Control Flow View
The Control flow view consists of four parts:

• List of procedures to explore (top left, green frame)
• Dependency tree (bottom left, purple frame)
• Language settings (top right, blue frame)
• Cross-references snippets (bottom right, yellow frame)

List of Procedures
The list of procedures lets you select a procedure whose call tree you want to
display. Click List Of Procedures to select a function, function block or task
(which are generally referred to as called “procedure” in the EcoStruxure Control
Engineering tools).
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Functions for finding a procedure:
• You can scroll through the list using the page buttons at the bottom of the

view. You can specify the number of procedures to be displayed on a single
page using the dropdown list at the top left part of the table.

• You can filter the procedures using the search field at the top right part of the
list. You can search by full or partial name of the procedure.

Click the name of a procedure to display it in the dependency tree and in the
cross-references snippets parts of the page.

Dependency Tree
The dependency tree is a graphical representation of the dependencies between
the procedures.

The selected procedure is highlighted in blue. Each linked procedure displayed to
its left is a procedure that calls it. Each linked procedure displayed to its right is a
procedure that is called by it.

You can explore the relationships between procedures by clicking their names.

This view is helpful to determine how the procedures call each other.

Language Settings
The language settings let you select Ladder or Literal as the language for the
cross-references snippets.

Depending on the different types of procedures, a representation of the code in
Ladder may not be available. In such a case, the cross-references snippets are
displayed in Literal.

Cross-References Snippets
The cross-references snippets part of the page displays how the different
procedures call each other.

It consists of a code extract (displayed in Ladder or Literal language) that
highlights the relations. The code extract is not displayed in the same way it is
written in the original code in order to provide a synthetic view. Its logic still
remains the same as in the original code. The logic can be retrieved using the
location displayed above each snippet.

For instance, if you call a procedure inside several nested conditional instructions,
the snippet compresses these instructions into a single one.
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The cross-references snippets view is updated each time you select a procedure
either in the list of procedures or in the dependency tree.
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Integration with SCADA
EcoStruxure Control Engineering - Monitoring provides a view that supplies only
the information relevant to a given variable. This view can be called from another
tool or displayed in a pop-up, since it is accessible via a URL. This URL comes in
the following format:

http://<@IP>/programs/view/<ABCDEF>/?entityname=
<entityname>&startmonitor=true

or

http://<@IP>/programs/view/<ABCDEF>/?entityaddress=%
<entityaddress>&startmonitor=true

The parameters found in the URL are:
• <@IP> - IP address of the server hosting EcoStruxure Control Engineering -

Monitoring tool
• <ABCDEF> is a program key that refers one program inside EcoStruxure

Control Engineering
• <entityname> or <entityaddress> corresponds to the name of the variable or

its address.
• startmonitor=true enables the automatic launch of the diagnostics and real-

time communication with the target (for example, the control system, the OPC
Server, etc.).

This view provides either the list of input variables that influence the output
variable passed as the parameter, or the list of output variables that may be
impacted by the input variable passed as the parameter.
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Downloading an Offline Version of the Representation
You can download a copy of the EcoStruxure Control Engineering - Monitoring
online results from the server to your local PC.

Download procedure:

Step Action

1 Navigate to the Program page.

2 Select Monitoring > Download (zip).

Result: A ZIP file with the representation in HTML format is downloaded to your PC.

3 Extract the contents of the downloaded ZIP file and open the file index.html if you want
to work with the downloaded representation.

NOTE: Security policies in your organization may keep your browser from
displaying certain or all HTML content stored on your PC. In such cases, contact
your administrator to resolve this condition.
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Manufacturer-Specific File Export Procedures
EcoStruxure Control Engineering tools use the source code files of controller
applications as input files. These files are exported from the corresponding
software development environments. The following sections provide information
on generating these export files in various software development environments.

EcoStruxure Control Expert (.XEF / .ZEF / .XVM File
Export)

Export the EcoStruxure Control Expert (formerly Unity Pro) controller application
to an XEF, ZEF or XVM export file in order to process them with EcoStruxure
Control Engineering tools.

To export the file, you can use the EcoStruxure Control Engineering Import/Export
tool. In the menu, select SUPPORT > DOWNLOADS.

It is also possible to export the files using the EcoStruxure Control Expert menu:

Step Action

1 From the menu, select File > Export application….

2 In the Export application… dialog box, provide a name for the XEF, ZEF or XVM file.

3 If required, modify the storage location for the XEF, ZEF or XVM file.

4 Click Save.
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EcoStruxure Machine Expert (.EXPORT File Export)
Export the EcoStruxure Machine Expert controller application to an XML export
file (with the extension .export) in order to be processed with EcoStruxure Control
Engineering tools.

Procedure:

Step Action

1 From the menu, select Project > Export….

2 You can export particular objects or a full tree. From the tabs in the Export dialog,
select the objects to be included in the export file.
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Step Action

NOTE: The checkbox One file per subtree allows you to generate separate
export files for the selected subtrees. You can export the file with a specific
EcoStruxure Machine Expert version that you select from the dropdown list
Storage version. To re-import the file, this EcoStruxure Machine Expert version is
used.

3 Click OK and provide a file name and a folder name as prompted.

4 Click Save.
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PL7 Pro (.FEF File Export)
Export the PL7 Pro controller application to an FEF export file in order to be
processed with EcoStruxure Control Engineering tools.

Prerequisites:

Step Action

1 Open the PL7 Pro configuration file Pl7sys.ini using a text editor. The file is located in
the Windows folder (for example, C:\Windows or C:\Winnt).

2 Search for the section [PL7TOOL132].

3 Verify that the entry ExportPl7Converter=True exists.

If the entry does not exist, add the entry in the section [PL7TOOL132].

4 Save the file.

The modification is taken into account with the next start of PL7 Pro.
NOTE: This feature is only available with version 4.5 or later of PL7 Pro.

Procedure:

Step Action

1 From the menu, select File > Export application….

2 In the Export application… dialog box, provide a name for the FEF file.

3 If required, modify the storage location for the FEF file.

4 Click Save.
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3S CODESYS V3 (.EXPORT File Export)
Export the CODESYS V3 controller application to an XML export file (with the
extension .export) in order to be processed with EcoStruxure Control Engineering
tools.

Procedure:

Step Action

1 From the menu, select Project > Export….

2 You can export particular objects or a full tree. From the tabs in the Export dialog,
select the objects to be included in the export file.

NOTE: The checkbox One file per subtree allows you to generate separate
export files for the selected subtrees. You can export the file with a specific
CODESYS version that you select from the dropdown list Storage version. This
version is then used to re-import the file in CODESYS. If you work on CODESYS
V3 code, select a version from the version 3 family (CODESYS V3 …).
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Step Action

3 Click OK.

4 Provide a file name and a folder name as prompted and click Save.
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3S CODESYS V2 (.EXP File Export)
Export the CODESYS V2 controller application to an EXP export file in order to be
processed with EcoStruxure Control Engineering tools.

Step Action

1 From the menu, select Project > Export….

2 In the Export Project dialog box, select the objects to be included in the export file
(with the default settings, a selected item has a blue background), then click OK.
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Step Action

3 Click OK and provide a file name and a folder name as prompted.

4 Click Save.
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BECKHOFF TwinCAT V3 (.XML File Export)
Export the Beckhoff TwinCAT controller application to an XML export file
(PLCopen) in order to be processed with EcoStruxure Control Engineering tools.

Step Action

1 In the Solution Explorer window, select the project.

2 Right-click the project and select Export PLCopenXML….

3 Click Save.
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PHOENIX CONTACT Multiprog v5.5 (.XML File Export)
Export the MULTIPROG controller application to an XML export file in order to be
processed with EcoStruxure Control Engineering tools.

Step Action

1 From the menu, select File > Export….

2 Select Export PLCopen xml file.

3 Provide a name for the export file.

4 Click Save.

As MULTIPROG can export the controller application in different versions of
PLCopen, there may be differences in the way your EcoStruxure Control
Engineering tool processes the export file, depending on the PLCopen version.
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Rockwell Automation® RSLogix 5000® or Studio 5000 (.
L5K File Export)

Export the Rockwell Automation® RSLogix 5000® controller application to a L5K
export file in order to be processed with EcoStruxure Control Engineering tools.

Step Action

1 From the menu, select File > Save as….

2 In the Save as… dialog box, provide a name for the L5K file.

3 If required, modify the storage location.

4 Select the file type: RSLogix 5000 Import/Export File (*.L5K).

5 Click Save.
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Siemens SIMATIC STEP 7 (.ASC, .AWL, .GR7 and .SCL File
Export)

Overview
The following steps are required to process a Siemens SIMATIC STEP 7
controller application with EcoStruxure Control Engineering tools:

• Set your SIMATIC STEP 7 workshop to German abbreviations (mnemonics).
• Create and export the symbols of the controller application to an .ASC file.
• Create and export the contact code (CONT) to an .AWL file.
• Create and export the graph blocks (GRAPH) to .GR7 files.
• Compile the CFC code (if any) to create the corresponding SCL sources.
• Export structural codes (SCL) to .SCL files.

Setting German Mnemonics
Before creating the export files, set your SIMATIC STEP 7 workshop to German
abbreviations (mnemonics):

Step Action

1 From the menu, select Options > Customize….

2 Display the Language tab.

3 Select German mnemonics.

4 Click OK.
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Creating an ASC File

Step Action

1 Right-click the Symbol Table in your program folder and select Open object.

2 From the menu of the Symbol Editor, select Symbol Table > Export….

3 Select ASCII Format (*.ASC).

4 Provide a name and select a directory for the .ASC export file.

5 Click Save.

Creating an AWL File
To create an .AWL file, first generate the LIST source for the code blocks
developed in the languages CONT, LIST and LOG.
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Step Action

1 Right-click a CONT, LIST or LOG source and select Open Object to open the CONT/
LIST/LOG code editor.

2 From the menu, select File > Close to close all open objects.

3 From the menu, select File > Generate source… to generate the program source.

4 Provide an object name and click OK.
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Step Action

5 Click All to select all program blocks and select the options Sort according to
program structure and Symbolic addresses.

6 Click OK to confirm.

If your controller application contains safety-related blocks, export those blocks in
a separate AWL file. Refer to Safety-Related Applications, page 67 for details.

Creating GR7 Files
The .GR7 sources must be created for each GRAPH blocks separately. Repeat
the following procedure for each GRAPH block to be exported.

Step Action

1 Right-click a GRAPH object and select Open Object.

2 From the menu, select File > Generate Source File.
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Step Action

3 Provide a name for the GRAPH object.

4 Click OK to confirm.

5 Repeat the procedure for each GRAPH object to be exported.

Creating a CFG File
The CFG file is required for analyzing the communication and the hardware
configuration of the station.

Step Action

1 Double-click your controller links in the main window to open NetPro.

2 In the NetPro window, double-click the controller of the station to be exported open the
HW Config utility.

3 From the Station menu, select Export… to export your station configuration (leave the
default settings in the dialog box).

Creating a SCL File for CFC Codes
If the controller application contains CFC code, compile the code to generate the
corresponding SCL source file which is the file to be processed with EcoStruxure
Control Engineering tools.
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Step Action

1 Open the CFC code editor by clicking its icon in the toolbar of the main window.

2 Compile the code with the options Entire program and Generate SCL sources and
click OK.

3 The generated SCL source file can then be exported like other source files (refer to
Exporting Files, page 70).

Safety-Related Applications
A safety-related controller application contains two code parts:

• The non-safety-related code part
• The safety-related code part

Procedure for exporting controller applications that contain safety-related code:
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Step Action

1 Export the .ASC file that contains the database for the safety-related code and for the
non-safety-related code (refer to Creating an ASC File, page 63).

2 Generate the sources for the non-safety-related code parts (refer to Creating an AWL
File, page 63 and Creating a GR7 File, page 65).

3 Click All to select all program blocks and select the options Sort according to
program structure and Symbolic addresses.

4 Click OK to confirm.

5 Follow the procedure for Creating an AWL File, page 63 until the dialog box Generate
source Safety is displayed.
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Step Action

6 Select the option User-created F-FBs, F-FCs and F-DBs and click OK to confirm.

7 Create a .dif file (refer to Creating a dif File, page 69). The .dif file is used to determine
whether code is safety-related.

Creating a dif File
A .dif file is created in the SIMATIC Manager of SIMATIC STEP 7 in the following
way:

Step Action

1 From the menu, select Options > Reference Data > Display.

2 In the Display S7 reference data dialog box, select the option regenerated? and click
Yes.
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Step Action

3 In the Customize dialog box, select the option Program Structure and click OK to
display the program structure.

4 From the menu, select View > Export to open the Save dialog box.

5 Provide a name for the .dif and click Save.

Exporting Files
After you have created the files, export them from SIMATIC STEP 7:

Step Action

1 Select the LIST, GRAPH (or .AWL and .GR7 files) and SCL sources that you have
generated.

2 Right-click the sources and select Export source….

3 Select a file name and a storage location and click Save.
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Siemens TIA Portal SIMATIC STEP 7 (.ZIP File Export)
Export the Siemens TIA Portal SIMATIC STEP 7 controller application to a ZIP
export file in order to be processed with EcoStruxure Control Engineering tools.

The export can be performed automatically with the EcoStruxure Control
Engineering - Import/Export tool. Select SUPPORT > DOWNLOADS.

Refer to the EcoStruxure Control Engineering - Import/Export user guide for
details on the export procedure.
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